SeriousBit.Ellipter Namespace

[image]

SeriousBit Ellipter Documentaton
SeriousBit.Ellipter Namespace
Send Feedback
Contains all classes and structures of SeriousBit Ellipter library

Classes

 | Class | Description
Public class | Crc16 | Calculates 16 bit cyclic redundancy check codes (CRC16).
Public class | Crc32 | Calculates 32 bit cyclic redundancy check codes (CRC32).
Public class | MachineInfoException | Represents errors that occur during Machine ID info calculation.
Public class | MachineInfoReader | Reads and calculates hardware and software info for computer identification.
Public class | SerialCreatedEventArgs | Occurs when a serial is generated
Public class | SerialException | Represents errors that occur during serial keys creation or verification.
Public class | SerialsManager | Creates and verifies serials based on asymmetric elliptic curves cryptography
Public class | TimeBomb | Provides functionality for time limited trial application
Public class | UsageBomb | Provides functionality for uses count limited trial application

Delegates

 | Delegate | Description
Public delegate | SerialCreatedEventHandler | Represents the method that will handle a SerialCreated event

Enumerations

 | Enumeration | Description
Public enumeration | BombState | Describes TimeBomb object's state
Public enumeration | KeyStrength | Determines the EC key strength.
Public enumeration | MachineInfo | Specifies constants that define hardware and software identification info types.


BombState Enumeration

[image]

SeriousBit Ellipter Documentaton
BombState Enumeration
See Also Send Feedback
Describes TimeBomb object's state

Namespace: SeriousBit.Ellipter
Assembly: SeriousBit.Ellipter (in SeriousBit.Ellipter.dll) Version: 2.0.0.0

Syntax

C#
public enum BombState
Visual Basic
Public Enumeration BombState
Visual C++
public enum class BombState

Members

Member name | Description
NonStarted |
TrialActive |
TrialExpired |
Hacked |

See Also

SeriousBit.Ellipter Namespace


Crc16 Class

[image]

SeriousBit Ellipter Documentaton
Crc16 Class
Members See Also Send Feedback
Calculates 16 bit cyclic redundancy check codes (CRC16).

Namespace: SeriousBit.Ellipter
Assembly: SeriousBit.Ellipter (in SeriousBit.Ellipter.dll) Version: 2.0.0.0

Syntax

C#
public static class Crc16
Visual Basic
Public NotInheritable Class Crc16
Visual C++
public ref class Crc16 abstract sealed

Inheritance Hierarchy

System..::..Object
SeriousBit.Ellipter..::..Crc16

See Also

Crc16 Members


Crc16 Members

[image] [image]

SeriousBit Ellipter Documentaton
Crc16 Members
Crc16 Class Methods See Also Send Feedback

Methods

Name | Description
Calculate(array<Byte>[]()[][]) | Computes a CRC16 from an array of bytes and returns a positive int of range [0-65535]
Calculate(String) | Computes a CRC16 from a string

See Also

Crc16 Class


Crc16 Methods

[image] [image]

SeriousBit Ellipter Documentaton
Crc16 Methods
Crc16 Class See Also Send Feedback

Methods

Name | Description
Calculate(array<Byte>[]()[][]) | Computes a CRC16 from an array of bytes and returns a positive int of range [0-65535]
Calculate(String) | Computes a CRC16 from a string

See Also

Crc16 Class


Calculate Method

[image] [image]

SeriousBit Ellipter Documentaton
Crc16..::..Calculate Method
Crc16 Class See Also Send Feedback

Overload List

Name | Description
Calculate(array<Byte>[]()[][]) | Computes a CRC16 from an array of bytes and returns a positive int of range [0-65535]
Calculate(String) | Computes a CRC16 from a string

See Also

Crc16 Class
Crc16 Members


Calculate Method (Byte[])

[image]

SeriousBit Ellipter Documentaton
Crc16..::..Calculate Method (array<Byte>[]()[][])
Crc16 Class See Also Send Feedback
Computes a CRC16 from an array of bytes and returns a positive int of range [0-65535]

Namespace: SeriousBit.Ellipter
Assembly: SeriousBit.Ellipter (in SeriousBit.Ellipter.dll) Version: 2.0.0.0

Syntax

C#
public static int Calculate(
    byte[] bytes
)
Visual Basic
Public Shared Function Calculate ( _
    bytes As Byte() _
) As Integer
Visual C++
public:
static int Calculate(
    array<unsigned char>^ bytes
)

Parameters

bytes
Type: array< System..::..Byte >[]()[][]

[Missing <param name="bytes"/> documentation for "M:SeriousBit.Ellipter.Crc16.Calculate(System.Byte[])"]

Return Value

[Missing <returns> documentation for "M:SeriousBit.Ellipter.Crc16.Calculate(System.Byte[])"]

See Also

Crc16 Class
Calculate Overload


Calculate Method (String)

[image]

SeriousBit Ellipter Documentaton
Crc16..::..Calculate Method (String)
Crc16 Class See Also Send Feedback
Computes a CRC16 from a string

Namespace: SeriousBit.Ellipter
Assembly: SeriousBit.Ellipter (in SeriousBit.Ellipter.dll) Version: 2.0.0.0

Syntax

C#
public static int Calculate(
    string data
)
Visual Basic
Public Shared Function Calculate ( _
    data As String _
) As Integer
Visual C++
public:
static int Calculate(
    String^ data
)

Parameters

data
Type: System..::..String

[Missing <param name="data"/> documentation for "M:SeriousBit.Ellipter.Crc16.Calculate(System.String)"]

Return Value

[Missing <returns> documentation for "M:SeriousBit.Ellipter.Crc16.Calculate(System.String)"]

See Also

Crc16 Class
Calculate Overload


Crc32 Class

[image]

SeriousBit Ellipter Documentaton
Crc32 Class
Members See Also Send Feedback
Calculates 32 bit cyclic redundancy check codes (CRC32).

Namespace: SeriousBit.Ellipter
Assembly: SeriousBit.Ellipter (in SeriousBit.Ellipter.dll) Version: 2.0.0.0

Syntax

C#
public static class Crc32
Visual Basic
Public NotInheritable Class Crc32
Visual C++
public ref class Crc32 abstract sealed

Inheritance Hierarchy

System..::..Object
SeriousBit.Ellipter..::..Crc32

See Also

Crc32 Members


Crc32 Members

[image] [image]

SeriousBit Ellipter Documentaton
Crc32 Members
Crc32 Class Methods See Also Send Feedback

The Crc32 type exposes the following members.

Methods

Name | Description
Calculate(array<Byte>[]()[][]) | Computes a CRC32 from an array of bytes
Calculate(String) | Computes a CRC32 from a string
CalculateToByteArray | Computes a CRC32 from an array of bytes and returns an array of 4 bytes

See Also

Crc32 Class


Crc32 Methods

[image] [image]

SeriousBit Ellipter Documentaton
Crc32 Methods
Crc32 Class See Also Send Feedback

The Crc32 type exposes the following members.

Methods

Name | Description
Calculate(array<Byte>[]()[][]) | Computes a CRC32 from an array of bytes
Calculate(String) | Computes a CRC32 from a string
CalculateToByteArray | Computes a CRC32 from an array of bytes and returns an array of 4 bytes

See Also

Crc32 Class


Calculate Method

[image] [image]

SeriousBit Ellipter Documentaton
Crc32..::..Calculate Method
Crc32 Class See Also Send Feedback

Overload List

Name | Description
Calculate(array<Byte>[]()[][]) | Computes a CRC32 from an array of bytes
Calculate(String) | Computes a CRC32 from a string

See Also

Crc32 Class
Crc32 Members


Calculate Method (Byte[])

[image]

SeriousBit Ellipter Documentaton
Crc32..::..Calculate Method (array<Byte>[]()[][])
Crc32 Class See Also Send Feedback
Computes a CRC32 from an array of bytes

Namespace: SeriousBit.Ellipter
Assembly: SeriousBit.Ellipter (in SeriousBit.Ellipter.dll) Version: 2.0.0.0

Syntax

C#
public static long Calculate(
    byte[] data
)
Visual Basic
Public Shared Function Calculate ( _
    data As Byte() _
) As Long
Visual C++
public:
static long long Calculate(
    array<unsigned char>^ data
)

Parameters

data
Type: array< System..::..Byte >[]()[][]

[Missing <param name="data"/> documentation for "M:SeriousBit.Ellipter.Crc32.Calculate(System.Byte[])"]

Return Value

A positive long

See Also

Crc32 Class
Calculate Overload


Calculate Method (String)

[image]

SeriousBit Ellipter Documentaton
Crc32..::..Calculate Method (String)
Crc32 Class See Also Send Feedback
Computes a CRC32 from a string

Namespace: SeriousBit.Ellipter
Assembly: SeriousBit.Ellipter (in SeriousBit.Ellipter.dll) Version: 2.0.0.0

Syntax

C#
public static long Calculate(
    string data
)
Visual Basic
Public Shared Function Calculate ( _
    data As String _
) As Long
Visual C++
public:
static long long Calculate(
    String^ data
)

Parameters

data
Type: System..::..String

[Missing <param name="data"/> documentation for "M:SeriousBit.Ellipter.Crc32.Calculate(System.String)"]

Return Value

A positive long

See Also

Crc32 Class
Calculate Overload


CalculateToByteArray Method

[image]

SeriousBit Ellipter Documentaton
Crc32..::..CalculateToByteArray Method
Crc32 Class See Also Send Feedback
Computes a CRC32 from an array of bytes and returns an array of 4 bytes

Namespace: SeriousBit.Ellipter
Assembly: SeriousBit.Ellipter (in SeriousBit.Ellipter.dll) Version: 2.0.0.0

Syntax

C#
public static byte[] CalculateToByteArray(
    byte[] bytes
)
Visual Basic
Public Shared Function CalculateToByteArray ( _
    bytes As Byte() _
) As Byte()
Visual C++
public:
static array<unsigned char>^ CalculateToByteArray(
    array<unsigned char>^ bytes
)

Parameters

bytes
Type: array< System..::..Byte >[]()[][]

[Missing <param name="bytes"/> documentation for "M:SeriousBit.Ellipter.Crc32.CalculateToByteArray(System.Byte[])"]

Return Value

[Missing <returns> documentation for "M:SeriousBit.Ellipter.Crc32.CalculateToByteArray(System.Byte[])"]

See Also

Crc32 Class


KeyStrength Enumeration

[image]

SeriousBit Ellipter Documentaton
KeyStrength Enumeration
See Also Send Feedback
Determines the EC key strength.

Namespace: SeriousBit.Ellipter
Assembly: SeriousBit.Ellipter (in SeriousBit.Ellipter.dll) Version: 2.0.0.0

Syntax

C#
public enum KeyStrength
Visual Basic
Public Enumeration KeyStrength
Visual C++
public enum class KeyStrength

Members

Member name | Description
Use128Bits |
Use160Bits |
Use192Bits |
Use224Bits |
Use256Bits |
Use384Bits |
Use521Bits |

See Also

SeriousBit.Ellipter Namespace


MachineInfo Enumeration

[image]

SeriousBit Ellipter Documentaton
MachineInfo Enumeration
See Also Send Feedback
Specifies constants that define hardware and software identification info types.

Namespace: SeriousBit.Ellipter
Assembly: SeriousBit.Ellipter (in SeriousBit.Ellipter.dll) Version: 2.0.0.0

Syntax

C#
public enum MachineInfo
Visual Basic
Public Enumeration MachineInfo
Visual C++
public enum class MachineInfo

Members

Member name | Description
ProcessorID |
MemoryAmount |
HddSerialNumber |
HddCapacity |
NetworkCardMac |
MainboardSerialNumber |
BiosVersion |
MachineName |
DomainName |
UserName |
UserSid |
MachineSid |

See Also

SeriousBit.Ellipter Namespace


MachineInfoException Class

[image]

SeriousBit Ellipter Documentaton
MachineInfoException Class
Members See Also Send Feedback
Represents errors that occur during Machine ID info calculation.

Namespace: SeriousBit.Ellipter
Assembly: SeriousBit.Ellipter (in SeriousBit.Ellipter.dll) Version: 2.0.0.0

Syntax

C#
public class MachineInfoException : Exception
Visual Basic
Public Class MachineInfoException _
    Inherits Exception
Visual C++
public ref class MachineInfoException : public Exception

Inheritance Hierarchy

System..::..Object
System..::..Exception
SeriousBit.Ellipter..::..MachineInfoException

See Also

MachineInfoException Members


MachineInfoException Members

[image] [image]

SeriousBit Ellipter Documentaton
MachineInfoException Members
MachineInfoException Class Constructors Methods Properties Events See Also Send Feedback

The MachineInfoException type exposes the following members.

Constructors

 | Name | Description
Public method | MachineInfoException()()()() | Initializes a new instance of the MachineInfoException class
Public method | MachineInfoException(String) | Initializes a new instance of the MachineInfoException class
Public method | MachineInfoException(SerializationInfo, StreamingContext) | Initializes a new instance of the MachineInfoException class
Public method | MachineInfoException(String, Exception) | Initializes a new instance of the MachineInfoException class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

Events

 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)

See Also

MachineInfoException Class


MachineInfoException Constructor

[image] [image]

SeriousBit Ellipter Documentaton
MachineInfoException Constructor
MachineInfoException Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MachineInfoException()()()() | Initializes a new instance of the MachineInfoException class
Public method | MachineInfoException(String) | Initializes a new instance of the MachineInfoException class
Public method | MachineInfoException(SerializationInfo, StreamingContext) | Initializes a new instance of the MachineInfoException class
Public method | MachineInfoException(String, Exception) | Initializes a new instance of the MachineInfoException class

See Also

MachineInfoException Class
MachineInfoException Members


MachineInfoException Constructor

[image]

SeriousBit Ellipter Documentaton
MachineInfoException Constructor
MachineInfoException Class See Also Send Feedback
Initializes a new instance of the MachineInfoException class

Namespace: SeriousBit.Ellipter
Assembly: SeriousBit.Ellipter (in SeriousBit.Ellipter.dll) Version: 2.0.0.0

Syntax

C#
public MachineInfoException()
Visual Basic
Public Sub New
Visual C++
public:
MachineInfoException()

See Also

MachineInfoException Class
MachineInfoException Overload


MachineInfoException Constructor (String)

[image]

SeriousBit Ellipter Documentaton
MachineInfoException Constructor (String)
MachineInfoException Class See Also Send Feedback
Initializes a new instance of the MachineInfoException class

Namespace: SeriousBit.Ellipter
Assembly: SeriousBit.Ellipter (in SeriousBit.Ellipter.dll) Version: 2.0.0.0

Syntax

C#
public MachineInfoException(
    string message
)
Visual Basic
Public Sub New ( _
    message As String _
)
Visual C++
public:
MachineInfoException(
    String^ message
)

Parameters

message
Type: System..::..String

[Missing <param name="message"/> documentation for "M:SeriousBit.Ellipter.MachineInfoException.#ctor(System.String)"]

See Also

MachineInfoException Class
MachineInfoException Overload


MachineInfoException Constructor (SerializationInfo, StreamingContext)

[image]

SeriousBit Ellipter Documentaton
MachineInfoException Constructor (SerializationInfo, StreamingContext)
MachineInfoException Class See Also Send Feedback
Initializes a new instance of the MachineInfoException class

Namespace: SeriousBit.Ellipter
Assembly: SeriousBit.Ellipter (in SeriousBit.Ellipter.dll) Version: 2.0.0.0

Syntax

C#
public MachineInfoException(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic
Public Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
public:
MachineInfoException(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.Serialization..::..SerializationInfo

[Missing <param name="info"/> documentation for "M:SeriousBit.Ellipter.MachineInfoException.#ctor(System.Runtime.Serialization.SerializationInfo,System.Runtime.Serialization.StreamingContext)"]

context
Type: System.Runtime.Serialization..::..StreamingContext

[Missing <param name="context"/> documentation for "M:SeriousBit.Ellipter.MachineInfoException.#ctor(System.Runtime.Serialization.SerializationInfo,System.Runtime.Serialization.StreamingContext)"]

See Also

MachineInfoException Class
MachineInfoException Overload


MachineInfoException Constructor (String, Exception)

[image]

SeriousBit Ellipter Documentaton
MachineInfoException Constructor (String, Exception)
MachineInfoException Class See Also Send Feedback
Initializes a new instance of the MachineInfoException class

Namespace: SeriousBit.Ellipter
Assembly: SeriousBit.Ellipter (in SeriousBit.Ellipter.dll) Version: 2.0.0.0

Syntax

C#
public MachineInfoException(
    string message,
    Exception innerException
)
Visual Basic
Public Sub New ( _
    message As String, _
    innerException As Exception _
)
Visual C++
public:
MachineInfoException(
    String^ message,
    Exception^ innerException
)

Parameters

message
Type: System..::..String

[Missing <param name="message"/> documentation for "M:SeriousBit.Ellipter.MachineInfoException.#ctor(System.String,System.Exception)"]

innerException
Type: System..::..Exception

[Missing <param name="innerException"/> documentation for "M:SeriousBit.Ellipter.MachineInfoException.#ctor(System.String,System.Exception)"]

See Also

MachineInfoException Class
MachineInfoException Overload


MachineInfoException Methods

[image] [image]

SeriousBit Ellipter Documentaton
MachineInfoException Methods
MachineInfoException Class See Also Send Feedback

The MachineInfoException type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

MachineInfoException Class


MachineInfoException Properties

[image] [image]

SeriousBit Ellipter Documentaton
MachineInfoException Properties
MachineInfoException Class See Also Send Feedback

The MachineInfoException type exposes the following members.

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

MachineInfoException Class


MachineInfoException Events

[image] [image]

SeriousBit Ellipter Documentaton
MachineInfoException Events
MachineInfoException Class See Also Send Feedback

The MachineInfoException type exposes the following members.

Events

 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)

See Also

MachineInfoException Class


MachineInfoReader Class

[image]

SeriousBit Ellipter Documentaton
MachineInfoReader Class
Members See Also Send Feedback
Reads and calculates hardware and software info for computer identification.

Namespace: SeriousBit.Ellipter
Assembly: SeriousBit.Ellipter (in SeriousBit.Ellipter.dll) Version: 2.0.0.0

Syntax

C#
public static class MachineInfoReader
Visual Basic
Public NotInheritable Class MachineInfoReader
Visual C++
public ref class MachineInfoReader abstract sealed

Inheritance Hierarchy

System..::..Object
SeriousBit.Ellipter..::..MachineInfoReader

See Also

MachineInfoReader Members


MachineInfoReader Members

[image] [image]

SeriousBit Ellipter Documentaton
MachineInfoReader Members
MachineInfoReader Class Methods See Also Send Feedback

The MachineInfoReader type exposes the following members.

Methods

Name | Description
GetBiosVersion | Gets BIOS version.
GetDomainName | Gets the domain the computer belongs to.
GetHddCapacities | Returns the capcacities in bytes of all hard drives on the running computer.
GetHddSerialNumbers | Returns the serials of all hard drives on the running computer.
GetMachineName | Gets the name of the computer.
GetMachineSid | Gets the machine's Security Identifier (SID).
GetMainboardSerialNumber | Gets the mainboards serial number. Throws an exception if no serial was found.
GetMemoryAmount | Gets the memory amount on the running computer.
GetNetworkCardMac | Gets the MACs of all network cards on the running computer.
GetProcessorID | Gets the processor ID. It is not unique.
GetUserName | Gets the current user's name.
GetUserSid | Gets the user's Security Identifier (SID).
ReadMachineID | Calculates the ID of the running machine by mixing all the hardware and software info corresponding to the provided parameters.

See Also

MachineInfoReader Class


MachineInfoReader Methods

[image] [image]

SeriousBit Ellipter Documentaton
MachineInfoReader Methods
MachineInfoReader Class See Also Send Feedback

The MachineInfoReader type exposes the following members.

Methods

Name | Description
GetBiosVersion | Gets BIOS version.
GetDomainName | Gets the domain the computer belongs to.
GetHddCapacities | Returns the capcacities in bytes of all hard drives on the running computer.
GetHddSerialNumbers | Returns the serials of all hard drives on the running computer.
GetMachineName | Gets the name of the computer.
GetMachineSid | Gets the machine's Security Identifier (SID).
GetMainboardSerialNumber | Gets the mainboards serial number. Throws an exception if no serial was found.
GetMemoryAmount | Gets the memory amount on the running computer.
GetNetworkCardMac | Gets the MACs of all network cards on the running computer.
GetProcessorID | Gets the processor ID. It is not unique.
GetUserName | Gets the current user's name.
GetUserSid | Gets the user's Security Identifier (SID).
ReadMachineID | Calculates the ID of the running machine by mixing all the hardware and software info corresponding to the provided parameters.

See Also

MachineInfoReader Class


GetBiosVersion Method

[image]

SeriousBit Ellipter Documentaton
MachineInfoReader..::..GetBiosVersion Method
MachineInfoReader Class See Also Send Feedback
Gets BIOS version.

Namespace: SeriousBit.Ellipter
Assembly: SeriousBit.Ellipter (in SeriousBit.Ellipter.dll) Version: 2.0.0.0

Syntax

C#
public static string GetBiosVersion()
Visual Basic
Public Shared Function GetBiosVersion As String
Visual C++
public:
static String^ GetBiosVersion()

Return Value

[Missing <returns> documentation for "M:SeriousBit.Ellipter.MachineInfoReader.GetBiosVersion"]

See Also

MachineInfoReader Class


GetDomainName Method

[image]

SeriousBit Ellipter Documentaton
MachineInfoReader..::..GetDomainName Method
MachineInfoReader Class See Also Send Feedback
Gets the domain the computer belongs to.

Namespace: SeriousBit.Ellipter
Assembly: SeriousBit.Ellipter (in SeriousBit.Ellipter.dll) Version: 2.0.0.0

Syntax

C#
public static string GetDomainName()
Visual Basic
Public Shared Function GetDomainName As String
Visual C++
public:
static String^ GetDomainName()

Return Value

[Missing <returns> documentation for "M:SeriousBit.Ellipter.MachineInfoReader.GetDomainName"]

See Also

MachineInfoReader Class


GetHddCapacities Method

[image]

SeriousBit Ellipter Documentaton
MachineInfoReader..::..GetHddCapacities Method
MachineInfoReader Class See Also Send Feedback
Returns the capcacities in bytes of all hard drives on the running computer.

Namespace: SeriousBit.Ellipter
Assembly: SeriousBit.Ellipter (in SeriousBit.Ellipter.dll) Version: 2.0.0.0

Syntax

C#
public static long[] GetHddCapacities()
Visual Basic
Public Shared Function GetHddCapacities As Long()
Visual C++
public:
static array<long long>^ GetHddCapacities()

Return Value

[Missing <returns> documentation for "M:SeriousBit.Ellipter.MachineInfoReader.GetHddCapacities"]

See Also

MachineInfoReader Class


GetHddSerialNumbers Method

[image]

SeriousBit Ellipter Documentaton
MachineInfoReader..::..GetHddSerialNumbers Method
MachineInfoReader Class See Also Send Feedback
Returns the serials of all hard drives on the running computer.

Namespace: SeriousBit.Ellipter
Assembly: SeriousBit.Ellipter (in SeriousBit.Ellipter.dll) Version: 2.0.0.0

Syntax

C#
public static string[] GetHddSerialNumbers()
Visual Basic
Public Shared Function GetHddSerialNumbers As String()
Visual C++
public:
static array<String^>^ GetHddSerialNumbers()

Return Value

[Missing <returns> documentation for "M:SeriousBit.Ellipter.MachineInfoReader.GetHddSerialNumbers"]

See Also

MachineInfoReader Class


GetMachineName Method

[image]

SeriousBit Ellipter Documentaton
MachineInfoReader..::..GetMachineName Method
MachineInfoReader Class See Also Send Feedback
Gets the name of the computer.

Namespace: SeriousBit.Ellipter
Assembly: SeriousBit.Ellipter (in SeriousBit.Ellipter.dll) Version: 2.0.0.0

Syntax

C#
public static string GetMachineName()
Visual Basic
Public Shared Function GetMachineName As String
Visual C++
public:
static String^ GetMachineName()

Return Value

[Missing <returns> documentation for "M:SeriousBit.Ellipter.MachineInfoReader.GetMachineName"]

See Also

MachineInfoReader Class


GetMachineSid Method

[image]

SeriousBit Ellipter Documentaton
MachineInfoReader..::..GetMachineSid Method
MachineInfoReader Class See Also Send Feedback
Gets the machine's Security Identifier (SID).

Namespace: SeriousBit.Ellipter
Assembly: SeriousBit.Ellipter (in SeriousBit.Ellipter.dll) Version: 2.0.0.0

Syntax

C#
public static string GetMachineSid()
Visual Basic
Public Shared Function GetMachineSid As String
Visual C++
public:
static String^ GetMachineSid()

Return Value

[Missing <returns> documentation for "M:SeriousBit.Ellipter.MachineInfoReader.GetMachineSid"]

See Also

MachineInfoReader Class


GetMainboardSerialNumber Method

[image]

SeriousBit Ellipter Documentaton
MachineInfoReader..::..GetMainboardSerialNumber Method
MachineInfoReader Class See Also Send Feedback
Gets the mainboards serial number. Throws an exception if no serial was found.

Namespace: SeriousBit.Ellipter
Assembly: SeriousBit.Ellipter (in SeriousBit.Ellipter.dll) Version: 2.0.0.0

Syntax

C#
public static string GetMainboardSerialNumber()
Visual Basic
Public Shared Function GetMainboardSerialNumber As String
Visual C++
public:
static String^ GetMainboardSerialNumber()

Return Value

[Missing <returns> documentation for "M:SeriousBit.Ellipter.MachineInfoReader.GetMainboardSerialNumber"]

See Also

MachineInfoReader Class


GetMemoryAmount Method

[image]

SeriousBit Ellipter Documentaton
MachineInfoReader..::..GetMemoryAmount Method
MachineInfoReader Class See Also Send Feedback
Gets the memory amount on the running computer.

Namespace: SeriousBit.Ellipter
Assembly: SeriousBit.Ellipter (in SeriousBit.Ellipter.dll) Version: 2.0.0.0

Syntax

C#
public static long GetMemoryAmount()
Visual Basic
Public Shared Function GetMemoryAmount As Long
Visual C++
public:
static long long GetMemoryAmount()

Return Value

[Missing <returns> documentation for "M:SeriousBit.Ellipter.MachineInfoReader.GetMemoryAmount"]

See Also

MachineInfoReader Class


GetNetworkCardMac Method

[image]

SeriousBit Ellipter Documentaton
MachineInfoReader..::..GetNetworkCardMac Method
MachineInfoReader Class See Also Send Feedback
Gets the MACs of all network cards on the running computer.

Namespace: SeriousBit.Ellipter
Assembly: SeriousBit.Ellipter (in SeriousBit.Ellipter.dll) Version: 2.0.0.0

Syntax

C#
public static string[] GetNetworkCardMac()
Visual Basic
Public Shared Function GetNetworkCardMac As String()
Visual C++
public:
static array<String^>^ GetNetworkCardMac()

Return Value

[Missing <returns> documentation for "M:SeriousBit.Ellipter.MachineInfoReader.GetNetworkCardMac"]

See Also

MachineInfoReader Class


GetProcessorID Method

[image]

SeriousBit Ellipter Documentaton
MachineInfoReader..::..GetProcessorID Method
MachineInfoReader Class See Also Send Feedback
Gets the processor ID. It is not unique.

Namespace: SeriousBit.Ellipter
Assembly: SeriousBit.Ellipter (in SeriousBit.Ellipter.dll) Version: 2.0.0.0

Syntax

C#
public static string GetProcessorID()
Visual Basic
Public Shared Function GetProcessorID As String
Visual C++
public:
static String^ GetProcessorID()

Return Value

[Missing <returns> documentation for "M:SeriousBit.Ellipter.MachineInfoReader.GetProcessorID"]

See Also

MachineInfoReader Class


GetUserName Method

[image]

SeriousBit Ellipter Documentaton
MachineInfoReader..::..GetUserName Method
MachineInfoReader Class See Also Send Feedback
Gets the current user's name.

Namespace: SeriousBit.Ellipter
Assembly: SeriousBit.Ellipter (in SeriousBit.Ellipter.dll) Version: 2.0.0.0

Syntax

C#
public static string GetUserName()
Visual Basic
Public Shared Function GetUserName As String
Visual C++
public:
static String^ GetUserName()

Return Value

[Missing <returns> documentation for "M:SeriousBit.Ellipter.MachineInfoReader.GetUserName"]

See Also

MachineInfoReader Class


GetUserSid Method

[image]

SeriousBit Ellipter Documentaton
MachineInfoReader..::..GetUserSid Method
MachineInfoReader Class See Also Send Feedback
Gets the user's Security Identifier (SID).

Namespace: SeriousBit.Ellipter
Assembly: SeriousBit.Ellipter (in SeriousBit.Ellipter.dll) Version: 2.0.0.0

Syntax

C#
public static string GetUserSid()
Visual Basic
Public Shared Function GetUserSid As String
Visual C++
public:
static String^ GetUserSid()

Return Value

[Missing <returns> documentation for "M:SeriousBit.Ellipter.MachineInfoReader.GetUserSid"]

See Also

MachineInfoReader Class


ReadMachineID Method

[image]

SeriousBit Ellipter Documentaton
MachineInfoReader..::..ReadMachineID Method
MachineInfoReader Class See Also Send Feedback
Calculates the ID of the running machine by mixing all the hardware and software info corresponding to the provided parameters.

Namespace: SeriousBit.Ellipter
Assembly: SeriousBit.Ellipter (in SeriousBit.Ellipter.dll) Version: 2.0.0.0

Syntax

C#
public static long ReadMachineID(
    params MachineInfo[] infoToUse
)
Visual Basic
Public Shared Function ReadMachineID ( _
    ParamArray infoToUse As MachineInfo() _
) As Long
Visual C++
public:
static long long ReadMachineID(
    ... array<MachineInfo>^ infoToUse
)

Parameters

infoToUse
Type: array< SeriousBit.Ellipter..::..MachineInfo >[]()[][]
Indicates which info should be mixed to create the machine ID.

Return Value

A positive long

See Also

MachineInfoReader Class


SerialCreatedEventArgs Class

[image]

SeriousBit Ellipter Documentaton
SerialCreatedEventArgs Class
Members See Also Send Feedback
Occurs when a serial is generated

Namespace: SeriousBit.Ellipter
Assembly: SeriousBit.Ellipter (in SeriousBit.Ellipter.dll) Version: 2.0.0.0

Syntax

C#
public class SerialCreatedEventArgs : EventArgs
Visual Basic
Public Class SerialCreatedEventArgs _
    Inherits EventArgs
Visual C++
public ref class SerialCreatedEventArgs : public EventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
SeriousBit.Ellipter..::..SerialCreatedEventArgs

See Also

SerialCreatedEventArgs Members


SerialCreatedEventArgs Members

[image] [image]

SeriousBit Ellipter Documentaton
SerialCreatedEventArgs Members
SerialCreatedEventArgs Class Constructors Methods Properties See Also Send Feedback

The SerialCreatedEventArgs type exposes the following members.

Constructors

 | Name | Description
Public method | SerialCreatedEventArgs | Initializes a new instance of the SerialCreatedEventArgs class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ID | Contains the ID of the created serial
Public property | PrivateKey | The private key used to generate the serial
Public property | ProductInfo | Contains the ProductInfo field of the created serial
Public property | Serial | Contains the created serial

See Also

SerialCreatedEventArgs Class


SerialCreatedEventArgs Constructor

[image]

SeriousBit Ellipter Documentaton
SerialCreatedEventArgs Constructor
SerialCreatedEventArgs Class See Also Send Feedback
Initializes a new instance of the SerialCreatedEventArgs class

Namespace: SeriousBit.Ellipter
Assembly: SeriousBit.Ellipter (in SeriousBit.Ellipter.dll) Version: 2.0.0.0

Syntax

C#
public SerialCreatedEventArgs(
    string serial,
    long id,
    string productInfo,
    string privateKey
)
Visual Basic
Public Sub New ( _
    serial As String, _
    id As Long, _
    productInfo As String, _
    privateKey As String _
)
Visual C++
public:
SerialCreatedEventArgs(
    String^ serial,
    long long id,
    String^ productInfo,
    String^ privateKey
)

Parameters

serial
Type: System..::..String

[Missing <param name="serial"/> documentation for "M:SeriousBit.Ellipter.SerialCreatedEventArgs.#ctor(System.String,System.Int64,System.String,System.String)"]

id
Type: System..::..Int64

[Missing <param name="id"/> documentation for "M:SeriousBit.Ellipter.SerialCreatedEventArgs.#ctor(System.String,System.Int64,System.String,System.String)"]

productInfo
Type: System..::..String

[Missing <param name="productInfo"/> documentation for "M:SeriousBit.Ellipter.SerialCreatedEventArgs.#ctor(System.String,System.Int64,System.String,System.String)"]

privateKey
Type: System..::..String

[Missing <param name="privateKey"/> documentation for "M:SeriousBit.Ellipter.SerialCreatedEventArgs.#ctor(System.String,System.Int64,System.String,System.String)"]

See Also

SerialCreatedEventArgs Class


SerialCreatedEventArgs Methods

[image] [image]

SeriousBit Ellipter Documentaton
SerialCreatedEventArgs Methods
SerialCreatedEventArgs Class See Also Send Feedback

The SerialCreatedEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

SerialCreatedEventArgs Class


SerialCreatedEventArgs Properties

[image] [image]

SeriousBit Ellipter Documentaton
SerialCreatedEventArgs Properties
SerialCreatedEventArgs Class See Also Send Feedback

The SerialCreatedEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | ID | Contains the ID of the created serial
Public property | PrivateKey | The private key used to generate the serial
Public property | ProductInfo | Contains the ProductInfo field of the created serial
Public property | Serial | Contains the created serial

See Also

SerialCreatedEventArgs Class


ID Property

[image]

SeriousBit Ellipter Documentaton
SerialCreatedEventArgs..::..ID Property
SerialCreatedEventArgs Class See Also Send Feedback
Contains the ID of the created serial

Namespace: SeriousBit.Ellipter
Assembly: SeriousBit.Ellipter (in SeriousBit.Ellipter.dll) Version: 2.0.0.0

Syntax

C#
public long ID { internal get; set; }
Visual Basic
Public Property ID As Long
    Friend Get
    Set
Visual C++
public:
property long long ID {
    internal: long long get ();
    void set (long long value);
}

See Also

SerialCreatedEventArgs Class


PrivateKey Property

[image]

SeriousBit Ellipter Documentaton
SerialCreatedEventArgs..::..PrivateKey Property
SerialCreatedEventArgs Class See Also Send Feedback
The private key used to generate the serial

Namespace: SeriousBit.Ellipter
Assembly: SeriousBit.Ellipter (in SeriousBit.Ellipter.dll) Version: 2.0.0.0

Syntax

C#
public string PrivateKey { internal get; set; }
Visual Basic
Public Property PrivateKey As String
    Friend Get
    Set
Visual C++
public:
property String^ PrivateKey {
    internal: String^ get ();
    void set (String^ value);
}

See Also

SerialCreatedEventArgs Class


ProductInfo Property

[image]

SeriousBit Ellipter Documentaton
SerialCreatedEventArgs..::..ProductInfo Property
SerialCreatedEventArgs Class See Also Send Feedback
Contains the ProductInfo field of the created serial

Namespace: SeriousBit.Ellipter
Assembly: SeriousBit.Ellipter (in SeriousBit.Ellipter.dll) Version: 2.0.0.0

Syntax

C#
public string ProductInfo { internal get; set; }
Visual Basic
Public Property ProductInfo As String
    Friend Get
    Set
Visual C++
public:
property String^ ProductInfo {
    internal: String^ get ();
    void set (String^ value);
}

See Also

SerialCreatedEventArgs Class


Serial Property

[image]

SeriousBit Ellipter Documentaton
SerialCreatedEventArgs..::..Serial Property
SerialCreatedEventArgs Class See Also Send Feedback
Contains the created serial

Namespace: SeriousBit.Ellipter
Assembly: SeriousBit.Ellipter (in SeriousBit.Ellipter.dll) Version: 2.0.0.0

Syntax

C#
public string Serial { get; set; }
Visual Basic
Public Property Serial As String
    Get
    Set
Visual C++
public:
property String^ Serial {
    String^ get ();
    void set (String^ value);
}

See Also

SerialCreatedEventArgs Class


SerialCreatedEventHandler Delegate

[image]

SeriousBit Ellipter Documentaton
SerialCreatedEventHandler Delegate
See Also Send Feedback
Represents the method that will handle a SerialCreated event

Namespace: SeriousBit.Ellipter
Assembly: SeriousBit.Ellipter (in SeriousBit.Ellipter.dll) Version: 2.0.0.0

Syntax

C#
public delegate void SerialCreatedEventHandler(
    Object sender,
    SerialCreatedEventArgs args
)
Visual Basic
Public Delegate Sub SerialCreatedEventHandler ( _
    sender As Object, _
    args As SerialCreatedEventArgs _
)
Visual C++
public delegate void SerialCreatedEventHandler(
    Object^ sender,
    SerialCreatedEventArgs^ args
)

Parameters

sender
Type: System..::..Object
args
Type: SeriousBit.Ellipter..::..SerialCreatedEventArgs

See Also

SeriousBit.Ellipter Namespace


SerialException Class

[image]

SeriousBit Ellipter Documentaton
SerialException Class
Members See Also Send Feedback
Represents errors that occur during serial keys creation or verification.

Namespace: SeriousBit.Ellipter
Assembly: SeriousBit.Ellipter (in SeriousBit.Ellipter.dll) Version: 2.0.0.0

Syntax

C#
public class SerialException : Exception
Visual Basic
Public Class SerialException _
    Inherits Exception
Visual C++
public ref class SerialException : public Exception

Inheritance Hierarchy

System..::..Object
System..::..Exception
SeriousBit.Ellipter..::..SerialException

See Also

SerialException Members


SerialException Members

[image] [image]

SeriousBit Ellipter Documentaton
SerialException Members
SerialException Class Constructors Methods Properties Events See Also Send Feedback

The SerialException type exposes the following members.

Constructors

 | Name | Description
Public method | SerialException()()()() | Initializes a new instance of the SerialException class
Public method | SerialException(String) | Initializes a new instance of the SerialException class
Public method | SerialException(SerializationInfo, StreamingContext) | Initializes a new instance of the SerialException class
Public method | SerialException(String, Exception) | Initializes a new instance of the SerialException class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

Events

 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)

See Also

SerialException Class


SerialException Constructor

[image] [image]

SeriousBit Ellipter Documentaton
SerialException Constructor
SerialException Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SerialException()()()() | Initializes a new instance of the SerialException class
Public method | SerialException(String) | Initializes a new instance of the SerialException class
Public method | SerialException(SerializationInfo, StreamingContext) | Initializes a new instance of the SerialException class
Public method | SerialException(String, Exception) | Initializes a new instance of the SerialException class

See Also

SerialException Class
SerialException Members


SerialException Constructor

[image]

SeriousBit Ellipter Documentaton
SerialException Constructor
SerialException Class See Also Send Feedback
Initializes a new instance of the SerialException class

Namespace: SeriousBit.Ellipter
Assembly: SeriousBit.Ellipter (in SeriousBit.Ellipter.dll) Version: 2.0.0.0

Syntax

C#
public SerialException()
Visual Basic
Public Sub New
Visual C++
public:
SerialException()

See Also

SerialException Class
SerialException Overload


SerialException Constructor (String)

[image]

SeriousBit Ellipter Documentaton
SerialException Constructor (String)
SerialException Class See Also Send Feedback
Initializes a new instance of the SerialException class

Namespace: SeriousBit.Ellipter
Assembly: SeriousBit.Ellipter (in SeriousBit.Ellipter.dll) Version: 2.0.0.0

Syntax

C#
public SerialException(
    string message
)
Visual Basic
Public Sub New ( _
    message As String _
)
Visual C++
public:
SerialException(
    String^ message
)

Parameters

message
Type: System..::..String

[Missing <param name="message"/> documentation for "M:SeriousBit.Ellipter.SerialException.#ctor(System.String)"]

See Also

SerialException Class
SerialException Overload


SerialException Constructor (SerializationInfo, StreamingContext)

[image]

SeriousBit Ellipter Documentaton
SerialException Constructor (SerializationInfo, StreamingContext)
SerialException Class See Also Send Feedback
Initializes a new instance of the SerialException class

Namespace: SeriousBit.Ellipter
Assembly: SeriousBit.Ellipter (in SeriousBit.Ellipter.dll) Version: 2.0.0.0

Syntax

C#
public SerialException(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic
Public Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
public:
SerialException(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.Serialization..::..SerializationInfo

[Missing <param name="info"/> documentation for "M:SeriousBit.Ellipter.SerialException.#ctor(System.Runtime.Serialization.SerializationInfo,System.Runtime.Serialization.StreamingContext)"]

context
Type: System.Runtime.Serialization..::..StreamingContext

[Missing <param name="context"/> documentation for "M:SeriousBit.Ellipter.SerialException.#ctor(System.Runtime.Serialization.SerializationInfo,System.Runtime.Serialization.StreamingContext)"]

See Also

SerialException Class
SerialException Overload


SerialException Constructor (String, Exception)

[image]

SeriousBit Ellipter Documentaton
SerialException Constructor (String, Exception)
SerialException Class See Also Send Feedback
Initializes a new instance of the SerialException class

Namespace: SeriousBit.Ellipter
Assembly: SeriousBit.Ellipter (in SeriousBit.Ellipter.dll) Version: 2.0.0.0

Syntax

C#
public SerialException(
    string message,
    Exception innerException
)
Visual Basic
Public Sub New ( _
    message As String, _
    innerException As Exception _
)
Visual C++
public:
SerialException(
    String^ message,
    Exception^ innerException
)

Parameters

message
Type: System..::..String

[Missing <param name="message"/> documentation for "M:SeriousBit.Ellipter.SerialException.#ctor(System.String,System.Exception)"]

innerException
Type: System..::..Exception

[Missing <param name="innerException"/> documentation for "M:SeriousBit.Ellipter.SerialException.#ctor(System.String,System.Exception)"]

See Also

SerialException Class
SerialException Overload


SerialException Methods

[image] [image]

SeriousBit Ellipter Documentaton
SerialException Methods
SerialException Class See Also Send Feedback

The SerialException type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

SerialException Class


SerialException Properties

[image] [image]

SeriousBit Ellipter Documentaton
SerialException Properties
SerialException Class See Also Send Feedback

The SerialException type exposes the following members.

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

SerialException Class


SerialException Events

[image] [image]

SeriousBit Ellipter Documentaton
SerialException Events
SerialException Class See Also Send Feedback

The SerialException type exposes the following members.

Events

 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)

See Also

SerialException Class


SerialsManager Class

[image]

SeriousBit Ellipter Documentaton
SerialsManager Class
Members See Also Send Feedback
Creates and verifies serials based on asymmetric elliptic curves cryptography

Namespace: SeriousBit.Ellipter
Assembly: SeriousBit.Ellipter (in SeriousBit.Ellipter.dll) Version: 2.0.0.0

Syntax

C#
public sealed class SerialsManager : Component
Visual Basic
Public NotInheritable Class SerialsManager _
    Inherits Component
Visual C++
public ref class SerialsManager sealed : public Component

Inheritance Hierarchy

System..::..Object
System..::..MarshalByRefObject
System.ComponentModel..::..Component
SeriousBit.Ellipter..::..SerialsManager

See Also

SerialsManager Members


SerialsManager Members

[image] [image]

SeriousBit Ellipter Documentaton
SerialsManager Members
SerialsManager Class Constructors Methods Properties Events See Also Send Feedback

The SerialsManager type exposes the following members.

Constructors

 | Name | Description
Public method | SerialsManager()()()() | Obsolete. Constructor
Public method | SerialsManager(KeyStrength) | Constructor.
Public method | SerialsManager(String, String) | Obsolete. Contructor
Public method | SerialsManager(String, String, KeyStrength) | Contructor

Methods

 | Name | Description
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | CreatePrivatePublicKeys | Creates public and private keys and puts them in PublikKey and PrivateKey properties
Public method | CreateSerial()()()() | Creates a serial with a random ID
Public method | CreateSerial(Int64, String) | Creates a serial
Public method | CreateSerial(Int64, DateTime, String) | Creates a serial
Public method | CreateSerials(Int64, Int64, String) | Creates a serial
Public method | CreateSerials(Int64, Int64, DateTime, String) | Creates a serial
Public method | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the Component and optionally releases the managed resources. (Inherited from Component.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | GetDate | Returns the date from serial. If no date is present in this serial then returns DateTime.MaxValue
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetID | Return the ID of serial
Public method | GetInfo | Returns product information from serial. If no information is present in this serial then returns null
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
 | GetMachineID | Obsolete.
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HasDate | Returns true if serial has a date embedded
Public method | HasInfoField | If serial has product information then returns true
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | IsDeveloperRegistered | For internal use only
Public method | IsValid | Returns true if the serial is valid when verified with current public key
Protected method | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Public method | RegisterDeveloper | For internal use only
Public method | StopCreatingSerials | Stops SerialManager from creating serials
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)

Properties

 | Name | Description
Public property | BlackList | List of IDs of serials which are blacklisted. For a blacklisted serial method IsValid() will always return false.
Protected property | CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | DeveloperName | Developer name on whom this component is registered
Public property | DeveloperSerial | Key provided by SeriousBit, to get one for free go to our site Whithout this key SerialsManager wouldn't work properly
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | IsCreatingSerials | If SerialsManger is creating serials at the moment then returns true
Public property | IsMono | Returns true if program is currently running under Mono Runtime
 | LibraryVersion | Returns the version of this library
Public property | MaxDate | Gets maximal expiration date possible for a serial
Public property | MinDate | Gets the minimal Date possible for a serial.
Public property | PrivateKey | Base32 string used to create serials. Must be generated by Ellipter programatically or by GUI.
Public property | PublicKey | Base32 string used to verify serials. Must be generated by Ellipter programatically or by GUI.
Public property | Site | Gets or sets the ISite of the Component. (Inherited from Component.)

Events

 | Name | Description
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose()()()() method. (Inherited from Component.)
Public event | SerialCreated | Occurs when a serial is created

See Also

SerialsManager Class


SerialsManager Constructor

[image] [image]

SeriousBit Ellipter Documentaton
SerialsManager Constructor
SerialsManager Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SerialsManager()()()() | Obsolete. Constructor
Public method | SerialsManager(KeyStrength) | Constructor.
Public method | SerialsManager(String, String) | Obsolete. Contructor
Public method | SerialsManager(String, String, KeyStrength) | Contructor

See Also

SerialsManager Class
SerialsManager Members


SerialsManager Constructor

[image]

SeriousBit Ellipter Documentaton
SerialsManager Constructor
SerialsManager Class See Also Send Feedback
Constructor

Namespace: SeriousBit.Ellipter
Assembly: SeriousBit.Ellipter (in SeriousBit.Ellipter.dll) Version: 2.0.0.0

Syntax

C#
[ObsoleteAttribute("This constructor is kept only for backward compatibility, and will be removed in a future version.")]
public SerialsManager()
Visual Basic
<ObsoleteAttribute("This constructor is kept only for backward compatibility, and will be removed in a future version.")> _
Public Sub New
Visual C++
[ObsoleteAttribute(L"This constructor is kept only for backward compatibility, and will be removed in a future version.")]
public:
SerialsManager()

See Also

SerialsManager Class
SerialsManager Overload


SerialsManager Constructor (KeyStrength)

[image]

SeriousBit Ellipter Documentaton
SerialsManager Constructor (KeyStrength)
SerialsManager Class See Also Send Feedback
Constructor.

Namespace: SeriousBit.Ellipter
Assembly: SeriousBit.Ellipter (in SeriousBit.Ellipter.dll) Version: 2.0.0.0

Syntax

C#
public SerialsManager(
    KeyStrength strength
)
Visual Basic
Public Sub New ( _
    strength As KeyStrength _
)
Visual C++
public:
SerialsManager(
    KeyStrength strength
)

Parameters

strength
Type: SeriousBit.Ellipter..::..KeyStrength
Determines the EC key stregth. The recommened and most optimal value is 128, but a higher value can be selected for even more security.

See Also

SerialsManager Class
SerialsManager Overload


SerialsManager Constructor (String, String)

[image]

SeriousBit Ellipter Documentaton
SerialsManager Constructor (String, String)
SerialsManager Class See Also Send Feedback
Contructor

Namespace: SeriousBit.Ellipter
Assembly: SeriousBit.Ellipter (in SeriousBit.Ellipter.dll) Version: 2.0.0.0

Syntax

C#
[ObsoleteAttribute("This constructor is kept only for backward compatibility, and will be removed in a future version.")]
public SerialsManager(
    string developerName,
    string developerSerial
)
Visual Basic
<ObsoleteAttribute("This constructor is kept only for backward compatibility, and will be removed in a future version.")> _
Public Sub New ( _
    developerName As String, _
    developerSerial As String _
)
Visual C++
[ObsoleteAttribute(L"This constructor is kept only for backward compatibility, and will be removed in a future version.")]
public:
SerialsManager(
    String^ developerName,
    String^ developerSerial
)

Parameters

developerName
Type: System..::..String
Developer's name
developerSerial
Type: System..::..String
Key provided by SeriousBit, to get one for free go to our site Whithout this key SerialsManager wouldn't work properly

See Also

SerialsManager Class
SerialsManager Overload


SerialsManager Constructor (String, String, KeyStrength)

[image]

SeriousBit Ellipter Documentaton
SerialsManager Constructor (String, String, KeyStrength)
SerialsManager Class See Also Send Feedback
Contructor

Namespace: SeriousBit.Ellipter
Assembly: SeriousBit.Ellipter (in SeriousBit.Ellipter.dll) Version: 2.0.0.0

Syntax

C#
public SerialsManager(
    string developerName,
    string developerSerial,
    KeyStrength strength
)
Visual Basic
Public Sub New ( _
    developerName As String, _
    developerSerial As String, _
    strength As KeyStrength _
)
Visual C++
public:
SerialsManager(
    String^ developerName,
    String^ developerSerial,
    KeyStrength strength
)

Parameters

developerName
Type: System..::..String
Developer's name
developerSerial
Type: System..::..String
Key provided by SeriousBit, to get one for free go to our site Whithout this key SerialsManager wouldn't work properly
strength
Type: SeriousBit.Ellipter..::..KeyStrength
Determines the EC key stregth. The recommened and most optimal value is 128, but a higher value can be selected for even more security.

See Also

SerialsManager Class
SerialsManager Overload


SerialsManager Methods

[image] [image]

SeriousBit Ellipter Documentaton
SerialsManager Methods
SerialsManager Class See Also Send Feedback

The SerialsManager type exposes the following members.

Methods

 | Name | Description
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | CreatePrivatePublicKeys | Creates public and private keys and puts them in PublikKey and PrivateKey properties
Public method | CreateSerial()()()() | Creates a serial with a random ID
Public method | CreateSerial(Int64, String) | Creates a serial
Public method | CreateSerial(Int64, DateTime, String) | Creates a serial
Public method | CreateSerials(Int64, Int64, String) | Creates a serial
Public method | CreateSerials(Int64, Int64, DateTime, String) | Creates a serial
Public method | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the Component and optionally releases the managed resources. (Inherited from Component.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | GetDate | Returns the date from serial. If no date is present in this serial then returns DateTime.MaxValue
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetID | Return the ID of serial
Public method | GetInfo | Returns product information from serial. If no information is present in this serial then returns null
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
 | GetMachineID | Obsolete.
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HasDate | Returns true if serial has a date embedded
Public method | HasInfoField | If serial has product information then returns true
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | IsDeveloperRegistered | For internal use only
Public method | IsValid | Returns true if the serial is valid when verified with current public key
Protected method | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Public method | RegisterDeveloper | For internal use only
Public method | StopCreatingSerials | Stops SerialManager from creating serials
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)

See Also

SerialsManager Class


CreatePrivatePublicKeys Method

[image]

SeriousBit Ellipter Documentaton
SerialsManager..::..CreatePrivatePublicKeys Method
SerialsManager Class See Also Send Feedback
Creates public and private keys and puts them in PublikKey and PrivateKey properties

Namespace: SeriousBit.Ellipter
Assembly: SeriousBit.Ellipter (in SeriousBit.Ellipter.dll) Version: 2.0.0.0

Syntax

C#
public void CreatePrivatePublicKeys()
Visual Basic
Public Sub CreatePrivatePublicKeys
Visual C++
public:
void CreatePrivatePublicKeys()

See Also

SerialsManager Class


CreateSerial Method

[image] [image]

SeriousBit Ellipter Documentaton
SerialsManager..::..CreateSerial Method
SerialsManager Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CreateSerial()()()() | Creates a serial with a random ID
Public method | CreateSerial(Int64, String) | Creates a serial
Public method | CreateSerial(Int64, DateTime, String) | Creates a serial

See Also

SerialsManager Class
SerialsManager Members


CreateSerial Method

[image]

SeriousBit Ellipter Documentaton
SerialsManager..::..CreateSerial Method
SerialsManager Class See Also Send Feedback
Creates a serial with a random ID

Namespace: SeriousBit.Ellipter
Assembly: SeriousBit.Ellipter (in SeriousBit.Ellipter.dll) Version: 2.0.0.0

Syntax

C#
public string CreateSerial()
Visual Basic
Public Function CreateSerial As String
Visual C++
public:
String^ CreateSerial()

Return Value

[Missing <returns> documentation for "M:SeriousBit.Ellipter.SerialsManager.CreateSerial"]

See Also

SerialsManager Class
CreateSerial Overload


CreateSerial Method (Int64, String)

[image]

SeriousBit Ellipter Documentaton
SerialsManager..::..CreateSerial Method (Int64, String)
SerialsManager Class See Also Send Feedback
Creates a serial

Namespace: SeriousBit.Ellipter
Assembly: SeriousBit.Ellipter (in SeriousBit.Ellipter.dll) Version: 2.0.0.0

Syntax

C#
public string CreateSerial(
    long id,
    string productInfo
)
Visual Basic
Public Function CreateSerial ( _
    id As Long, _
    productInfo As String _
) As String
Visual C++
public:
String^ CreateSerial(
    long long id,
    String^ productInfo
)

Parameters

id
Type: System..::..Int64
A positive order number. Serials created with the same ID and Private Key are identical
productInfo
Type: System..::..String
Any string which will be included into serial. Maximum length allowed is 13 chars

Return Value

[Missing <returns> documentation for "M:SeriousBit.Ellipter.SerialsManager.CreateSerial(System.Int64,System.String)"]

See Also

SerialsManager Class
CreateSerial Overload


CreateSerial Method (Int64, DateTime, String)

[image]

SeriousBit Ellipter Documentaton
SerialsManager..::..CreateSerial Method (Int64, DateTime, String)
SerialsManager Class See Also Send Feedback
Creates a serial

Namespace: SeriousBit.Ellipter
Assembly: SeriousBit.Ellipter (in SeriousBit.Ellipter.dll) Version: 2.0.0.0

Syntax

C#
public string CreateSerial(
    long id,
    DateTime date,
    string productInfo
)
Visual Basic
Public Function CreateSerial ( _
    id As Long, _
    date As DateTime, _
    productInfo As String _
) As String
Visual C++
public:
String^ CreateSerial(
    long long id,
    DateTime date,
    String^ productInfo
)

Parameters

id
Type: System..::..Int64
A positive order number. Serials created with the same ID and Private Key are identical
date
Type: System..::..DateTime
The date to be stored in the serial
productInfo
Type: System..::..String
Any string which will be included into serial. Maximum length allowed is 13 chars

Return Value

[Missing <returns> documentation for "M:SeriousBit.Ellipter.SerialsManager.CreateSerial(System.Int64,System.DateTime,System.String)"]

See Also

SerialsManager Class
CreateSerial Overload


CreateSerials Method

[image] [image]

SeriousBit Ellipter Documentaton
SerialsManager..::..CreateSerials Method
SerialsManager Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CreateSerials(Int64, Int64, String) | Creates a serial
Public method | CreateSerials(Int64, Int64, DateTime, String) | Creates a serial

See Also

SerialsManager Class
SerialsManager Members


CreateSerials Method (Int64, Int64, String)

[image]

SeriousBit Ellipter Documentaton
SerialsManager..::..CreateSerials Method (Int64, Int64, String)
SerialsManager Class See Also Send Feedback
Creates a serial

Namespace: SeriousBit.Ellipter
Assembly: SeriousBit.Ellipter (in SeriousBit.Ellipter.dll) Version: 2.0.0.0

Syntax

C#
public string[] CreateSerials(
    long startID,
    long endID,
    string productInfo
)
Visual Basic
Public Function CreateSerials ( _
    startID As Long, _
    endID As Long, _
    productInfo As String _
) As String()
Visual C++
public:
array<String^>^ CreateSerials(
    long long startID,
    long long endID,
    String^ productInfo
)

Parameters

startID
Type: System..::..Int64
ID from which the serial generation will be started
endID
Type: System..::..Int64
ID at which the serial generation will be ended. Must be biger than startID
productInfo
Type: System..::..String
Any string which will be included into serial. Maximum length allowed is 13 chars

Return Value

[Missing <returns> documentation for "M:SeriousBit.Ellipter.SerialsManager.CreateSerials(System.Int64,System.Int64,System.String)"]

See Also

SerialsManager Class
CreateSerials Overload


CreateSerials Method (Int64, Int64, DateTime, String)

[image]

SeriousBit Ellipter Documentaton
SerialsManager..::..CreateSerials Method (Int64, Int64, DateTime, String)
SerialsManager Class See Also Send Feedback
Creates a serial

Namespace: SeriousBit.Ellipter
Assembly: SeriousBit.Ellipter (in SeriousBit.Ellipter.dll) Version: 2.0.0.0

Syntax

C#
public string[] CreateSerials(
    long startID,
    long endID,
    DateTime date,
    string productInfo
)
Visual Basic
Public Function CreateSerials ( _
    startID As Long, _
    endID As Long, _
    date As DateTime, _
    productInfo As String _
) As String()
Visual C++
public:
array<String^>^ CreateSerials(
    long long startID,
    long long endID,
    DateTime date,
    String^ productInfo
)

Parameters

startID
Type: System..::..Int64
ID from which the serial generation will be started
endID
Type: System..::..Int64
ID at which the serial generation will be ended. Must be biger than startID
date
Type: System..::..DateTime
The date to be stored in the serial
productInfo
Type: System..::..String
Any string which will be included into serial. Maximum length allowed is 13 chars

Return Value

[Missing <returns> documentation for "M:SeriousBit.Ellipter.SerialsManager.CreateSerials(System.Int64,System.Int64,System.DateTime,System.String)"]

See Also

SerialsManager Class
CreateSerials Overload


Dispose Method

[image] [image]

SeriousBit Ellipter Documentaton
SerialsManager..::..Dispose Method
SerialsManager Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the Component and optionally releases the managed resources. (Inherited from Component.)

See Also

SerialsManager Class
SerialsManager Members


GetDate Method

[image]

SeriousBit Ellipter Documentaton
SerialsManager..::..GetDate Method
SerialsManager Class See Also Send Feedback
Returns the date from serial. If no date is present in this serial then returns DateTime.MaxValue

Namespace: SeriousBit.Ellipter
Assembly: SeriousBit.Ellipter (in SeriousBit.Ellipter.dll) Version: 2.0.0.0

Syntax

C#
public DateTime GetDate(
    string serial
)
Visual Basic
Public Function GetDate ( _
    serial As String _
) As DateTime
Visual C++
public:
DateTime GetDate(
    String^ serial
)

Parameters

serial
Type: System..::..String

[Missing <param name="serial"/> documentation for "M:SeriousBit.Ellipter.SerialsManager.GetDate(System.String)"]

Return Value

[Missing <returns> documentation for "M:SeriousBit.Ellipter.SerialsManager.GetDate(System.String)"]

See Also

SerialsManager Class


GetID Method

[image]

SeriousBit Ellipter Documentaton
SerialsManager..::..GetID Method
SerialsManager Class See Also Send Feedback
Return the ID of serial

Namespace: SeriousBit.Ellipter
Assembly: SeriousBit.Ellipter (in SeriousBit.Ellipter.dll) Version: 2.0.0.0

Syntax

C#
public long GetID(
    string serial
)
Visual Basic
Public Function GetID ( _
    serial As String _
) As Long
Visual C++
public:
long long GetID(
    String^ serial
)

Parameters

serial
Type: System..::..String

[Missing <param name="serial"/> documentation for "M:SeriousBit.Ellipter.SerialsManager.GetID(System.String)"]

Return Value

[Missing <returns> documentation for "M:SeriousBit.Ellipter.SerialsManager.GetID(System.String)"]

See Also

SerialsManager Class


GetInfo Method

[image]

SeriousBit Ellipter Documentaton
SerialsManager..::..GetInfo Method
SerialsManager Class See Also Send Feedback
Returns product information from serial. If no information is present in this serial then returns null

Namespace: SeriousBit.Ellipter
Assembly: SeriousBit.Ellipter (in SeriousBit.Ellipter.dll) Version: 2.0.0.0

Syntax

C#
public string GetInfo(
    string serial
)
Visual Basic
Public Function GetInfo ( _
    serial As String _
) As String
Visual C++
public:
String^ GetInfo(
    String^ serial
)

Parameters

serial
Type: System..::..String

[Missing <param name="serial"/> documentation for "M:SeriousBit.Ellipter.SerialsManager.GetInfo(System.String)"]

Return Value

[Missing <returns> documentation for "M:SeriousBit.Ellipter.SerialsManager.GetInfo(System.String)"]

See Also

SerialsManager Class


GetMachineID Method

[image]

SeriousBit Ellipter Documentaton
SerialsManager..::..GetMachineID Method
SerialsManager Class See Also Send Feedback

[Missing <summary> documentation for "M:SeriousBit.Ellipter.SerialsManager.GetMachineID"]

Namespace: SeriousBit.Ellipter
Assembly: SeriousBit.Ellipter (in SeriousBit.Ellipter.dll) Version: 2.0.0.0

Syntax

C#
[ObsoleteAttribute("Use MachineInfoReader instead.")]
public static long GetMachineID()
Visual Basic
<ObsoleteAttribute("Use MachineInfoReader instead.")> _
Public Shared Function GetMachineID As Long
Visual C++
[ObsoleteAttribute(L"Use MachineInfoReader instead.")]
public:
static long long GetMachineID()

Return Value

[Missing <returns> documentation for "M:SeriousBit.Ellipter.SerialsManager.GetMachineID"]

See Also

SerialsManager Class


HasDate Method

[image]

SeriousBit Ellipter Documentaton
SerialsManager..::..HasDate Method
SerialsManager Class See Also Send Feedback
Returns true if serial has a date embedded

Namespace: SeriousBit.Ellipter
Assembly: SeriousBit.Ellipter (in SeriousBit.Ellipter.dll) Version: 2.0.0.0

Syntax

C#
public bool HasDate(
    string serial
)
Visual Basic
Public Function HasDate ( _
    serial As String _
) As Boolean
Visual C++
public:
bool HasDate(
    String^ serial
)

Parameters

serial
Type: System..::..String

[Missing <param name="serial"/> documentation for "M:SeriousBit.Ellipter.SerialsManager.HasDate(System.String)"]

Return Value

[Missing <returns> documentation for "M:SeriousBit.Ellipter.SerialsManager.HasDate(System.String)"]

See Also

SerialsManager Class


HasInfoField Method

[image]

SeriousBit Ellipter Documentaton
SerialsManager..::..HasInfoField Method
SerialsManager Class See Also Send Feedback
If serial has product information then returns true

Namespace: SeriousBit.Ellipter
Assembly: SeriousBit.Ellipter (in SeriousBit.Ellipter.dll) Version: 2.0.0.0

Syntax

C#
public bool HasInfoField(
    string serial
)
Visual Basic
Public Function HasInfoField ( _
    serial As String _
) As Boolean
Visual C++
public:
bool HasInfoField(
    String^ serial
)

Parameters

serial
Type: System..::..String

[Missing <param name="serial"/> documentation for "M:SeriousBit.Ellipter.SerialsManager.HasInfoField(System.String)"]

Return Value

[Missing <returns> documentation for "M:SeriousBit.Ellipter.SerialsManager.HasInfoField(System.String)"]

See Also

SerialsManager Class


IsDeveloperRegistered Method

[image]

SeriousBit Ellipter Documentaton
SerialsManager..::..IsDeveloperRegistered Method
SerialsManager Class See Also Send Feedback
For internal use only

Namespace: SeriousBit.Ellipter
Assembly: SeriousBit.Ellipter (in SeriousBit.Ellipter.dll) Version: 2.0.0.0

Syntax

C#
public bool IsDeveloperRegistered()
Visual Basic
Public Function IsDeveloperRegistered As Boolean
Visual C++
public:
bool IsDeveloperRegistered()

Return Value

[Missing <returns> documentation for "M:SeriousBit.Ellipter.SerialsManager.IsDeveloperRegistered"]

See Also

SerialsManager Class


IsValid Method

[image]

SeriousBit Ellipter Documentaton
SerialsManager..::..IsValid Method
SerialsManager Class See Also Send Feedback
Returns true if the serial is valid when verified with current public key

Namespace: SeriousBit.Ellipter
Assembly: SeriousBit.Ellipter (in SeriousBit.Ellipter.dll) Version: 2.0.0.0

Syntax

C#
public bool IsValid(
    string serial
)
Visual Basic
Public Function IsValid ( _
    serial As String _
) As Boolean
Visual C++
public:
bool IsValid(
    String^ serial
)

Parameters

serial
Type: System..::..String
Base33 string with serial

Return Value

[Missing <returns> documentation for "M:SeriousBit.Ellipter.SerialsManager.IsValid(System.String)"]

See Also

SerialsManager Class


MemberwiseClone Method

[image] [image]

SeriousBit Ellipter Documentaton
SerialsManager..::..MemberwiseClone Method
SerialsManager Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

SerialsManager Class
SerialsManager Members


RegisterDeveloper Method

[image]

SeriousBit Ellipter Documentaton
SerialsManager..::..RegisterDeveloper Method
SerialsManager Class See Also Send Feedback
For internal use only

Namespace: SeriousBit.Ellipter
Assembly: SeriousBit.Ellipter (in SeriousBit.Ellipter.dll) Version: 2.0.0.0

Syntax

C#
public bool RegisterDeveloper(
    string devName,
    string devSerial
)
Visual Basic
Public Function RegisterDeveloper ( _
    devName As String, _
    devSerial As String _
) As Boolean
Visual C++
public:
bool RegisterDeveloper(
    String^ devName,
    String^ devSerial
)

Parameters

devName
Type: System..::..String

[Missing <param name="devName"/> documentation for "M:SeriousBit.Ellipter.SerialsManager.RegisterDeveloper(System.String,System.String)"]

devSerial
Type: System..::..String

[Missing <param name="devSerial"/> documentation for "M:SeriousBit.Ellipter.SerialsManager.RegisterDeveloper(System.String,System.String)"]

Return Value

[Missing <returns> documentation for "M:SeriousBit.Ellipter.SerialsManager.RegisterDeveloper(System.String,System.String)"]

See Also

SerialsManager Class


StopCreatingSerials Method

[image]

SeriousBit Ellipter Documentaton
SerialsManager..::..StopCreatingSerials Method
SerialsManager Class See Also Send Feedback
Stops SerialManager from creating serials

Namespace: SeriousBit.Ellipter
Assembly: SeriousBit.Ellipter (in SeriousBit.Ellipter.dll) Version: 2.0.0.0

Syntax

C#
public void StopCreatingSerials()
Visual Basic
Public Sub StopCreatingSerials
Visual C++
public:
void StopCreatingSerials()

See Also

SerialsManager Class


SerialsManager Properties

[image] [image]

SeriousBit Ellipter Documentaton
SerialsManager Properties
SerialsManager Class See Also Send Feedback

The SerialsManager type exposes the following members.

Properties

 | Name | Description
Public property | BlackList | List of IDs of serials which are blacklisted. For a blacklisted serial method IsValid() will always return false.
Protected property | CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | DeveloperName | Developer name on whom this component is registered
Public property | DeveloperSerial | Key provided by SeriousBit, to get one for free go to our site Whithout this key SerialsManager wouldn't work properly
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | IsCreatingSerials | If SerialsManger is creating serials at the moment then returns true
Public property | IsMono | Returns true if program is currently running under Mono Runtime
 | LibraryVersion | Returns the version of this library
Public property | MaxDate | Gets maximal expiration date possible for a serial
Public property | MinDate | Gets the minimal Date possible for a serial.
Public property | PrivateKey | Base32 string used to create serials. Must be generated by Ellipter programatically or by GUI.
Public property | PublicKey | Base32 string used to verify serials. Must be generated by Ellipter programatically or by GUI.
Public property | Site | Gets or sets the ISite of the Component. (Inherited from Component.)

See Also

SerialsManager Class


BlackList Property

[image]

SeriousBit Ellipter Documentaton
SerialsManager..::..BlackList Property
SerialsManager Class See Also Send Feedback
List of IDs of serials which are blacklisted. For a blacklisted serial method IsValid() will always return false.

Namespace: SeriousBit.Ellipter
Assembly: SeriousBit.Ellipter (in SeriousBit.Ellipter.dll) Version: 2.0.0.0

Syntax

C#
public long[] BlackList { get; set; }
Visual Basic
Public Property BlackList As Long()
    Get
    Set
Visual C++
public:
property array<long long>^ BlackList {
    array<long long>^ get ();
    void set (array<long long>^ value);
}

See Also

SerialsManager Class


DeveloperName Property

[image]

SeriousBit Ellipter Documentaton
SerialsManager..::..DeveloperName Property
SerialsManager Class See Also Send Feedback
Developer name on whom this component is registered

Namespace: SeriousBit.Ellipter
Assembly: SeriousBit.Ellipter (in SeriousBit.Ellipter.dll) Version: 2.0.0.0

Syntax

C#
public string DeveloperName { get; set; }
Visual Basic
Public Property DeveloperName As String
    Get
    Set
Visual C++
public:
property String^ DeveloperName {
    String^ get ();
    void set (String^ value);
}

See Also

SerialsManager Class


DeveloperSerial Property

[image]

SeriousBit Ellipter Documentaton
SerialsManager..::..DeveloperSerial Property
SerialsManager Class See Also Send Feedback
Key provided by SeriousBit, to get one for free go to our site Whithout this key SerialsManager wouldn't work properly

Namespace: SeriousBit.Ellipter
Assembly: SeriousBit.Ellipter (in SeriousBit.Ellipter.dll) Version: 2.0.0.0

Syntax

C#
public string DeveloperSerial { get; set; }
Visual Basic
Public Property DeveloperSerial As String
    Get
    Set
Visual C++
public:
property String^ DeveloperSerial {
    String^ get ();
    void set (String^ value);
}

See Also

SerialsManager Class


IsCreatingSerials Property

[image]

SeriousBit Ellipter Documentaton
SerialsManager..::..IsCreatingSerials Property
SerialsManager Class See Also Send Feedback
If SerialsManger is creating serials at the moment then returns true

Namespace: SeriousBit.Ellipter
Assembly: SeriousBit.Ellipter (in SeriousBit.Ellipter.dll) Version: 2.0.0.0

Syntax

C#
public bool IsCreatingSerials { get; private set; }
Visual Basic
Public Property IsCreatingSerials As Boolean
    Get
    Private Set
Visual C++
public:
property bool IsCreatingSerials {
    bool get ();
    private: void set (bool value);
}

See Also

SerialsManager Class


IsMono Property

[image]

SeriousBit Ellipter Documentaton
SerialsManager..::..IsMono Property
SerialsManager Class See Also Send Feedback
Returns true if program is currently running under Mono Runtime

Namespace: SeriousBit.Ellipter
Assembly: SeriousBit.Ellipter (in SeriousBit.Ellipter.dll) Version: 2.0.0.0

Syntax

C#
public bool IsMono { get; }
Visual Basic
Public ReadOnly Property IsMono As Boolean
    Get
Visual C++
public:
property bool IsMono {
    bool get ();
}

See Also

SerialsManager Class


LibraryVersion Property

[image]

SeriousBit Ellipter Documentaton
SerialsManager..::..LibraryVersion Property
SerialsManager Class See Also Send Feedback
Returns the version of this library

Namespace: SeriousBit.Ellipter
Assembly: SeriousBit.Ellipter (in SeriousBit.Ellipter.dll) Version: 2.0.0.0

Syntax

C#
public static string LibraryVersion { get; }
Visual Basic
Public Shared ReadOnly Property LibraryVersion As String
    Get
Visual C++
public:
static property String^ LibraryVersion {
    String^ get ();
}

See Also

SerialsManager Class


MaxDate Property

[image]

SeriousBit Ellipter Documentaton
SerialsManager..::..MaxDate Property
SerialsManager Class See Also Send Feedback
Gets maximal expiration date possible for a serial

Namespace: SeriousBit.Ellipter
Assembly: SeriousBit.Ellipter (in SeriousBit.Ellipter.dll) Version: 2.0.0.0

Syntax

C#
public DateTime MaxDate { get; }
Visual Basic
Public ReadOnly Property MaxDate As DateTime
    Get
Visual C++
public:
property DateTime MaxDate {
    DateTime get ();
}

See Also

SerialsManager Class


MinDate Property

[image]

SeriousBit Ellipter Documentaton
SerialsManager..::..MinDate Property
SerialsManager Class See Also Send Feedback
Gets the minimal Date possible for a serial.

Namespace: SeriousBit.Ellipter
Assembly: SeriousBit.Ellipter (in SeriousBit.Ellipter.dll) Version: 2.0.0.0

Syntax

C#
public DateTime MinDate { get; }
Visual Basic
Public ReadOnly Property MinDate As DateTime
    Get
Visual C++
public:
property DateTime MinDate {
    DateTime get ();
}

See Also

SerialsManager Class


PrivateKey Property

[image]

SeriousBit Ellipter Documentaton
SerialsManager..::..PrivateKey Property
SerialsManager Class See Also Send Feedback
Base32 string used to create serials. Must be generated by Ellipter programatically or by GUI.

Namespace: SeriousBit.Ellipter
Assembly: SeriousBit.Ellipter (in SeriousBit.Ellipter.dll) Version: 2.0.0.0

Syntax

C#
public string PrivateKey { get; set; }
Visual Basic
Public Property PrivateKey As String
    Get
    Set
Visual C++
public:
property String^ PrivateKey {
    String^ get ();
    void set (String^ value);
}

See Also

SerialsManager Class


PublicKey Property

[image]

SeriousBit Ellipter Documentaton
SerialsManager..::..PublicKey Property
SerialsManager Class See Also Send Feedback
Base32 string used to verify serials. Must be generated by Ellipter programatically or by GUI.

Namespace: SeriousBit.Ellipter
Assembly: SeriousBit.Ellipter (in SeriousBit.Ellipter.dll) Version: 2.0.0.0

Syntax

C#
public string PublicKey { get; set; }
Visual Basic
Public Property PublicKey As String
    Get
    Set
Visual C++
public:
property String^ PublicKey {
    String^ get ();
    void set (String^ value);
}

See Also

SerialsManager Class


SerialsManager Events

[image] [image]

SeriousBit Ellipter Documentaton
SerialsManager Events
SerialsManager Class See Also Send Feedback

The SerialsManager type exposes the following members.

Events

 | Name | Description
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose()()()() method. (Inherited from Component.)
Public event | SerialCreated | Occurs when a serial is created

See Also

SerialsManager Class


SerialCreated Event

[image]

SeriousBit Ellipter Documentaton
SerialsManager..::..SerialCreated Event
SerialsManager Class See Also Send Feedback
Occurs when a serial is created

Namespace: SeriousBit.Ellipter
Assembly: SeriousBit.Ellipter (in SeriousBit.Ellipter.dll) Version: 2.0.0.0

Syntax

C#
public event SerialCreatedEventHandler SerialCreated
Visual Basic
Public Event SerialCreated As SerialCreatedEventHandler
Visual C++
public:
 event SerialCreatedEventHandler^ SerialCreated {
    void add (SerialCreatedEventHandler^ value);
    void remove (SerialCreatedEventHandler^ value);
}

See Also

SerialsManager Class


TimeBomb Class

[image]

SeriousBit Ellipter Documentaton
TimeBomb Class
Members See Also Send Feedback
Provides functionality for time limited trial application

Namespace: SeriousBit.Ellipter
Assembly: SeriousBit.Ellipter (in SeriousBit.Ellipter.dll) Version: 2.0.0.0

Syntax

C#
public class TimeBomb : IDisposable
Visual Basic
Public Class TimeBomb _
    Implements IDisposable
Visual C++
public ref class TimeBomb : IDisposable

Inheritance Hierarchy

System..::..Object
SeriousBit.Ellipter..::..TimeBomb

See Also

TimeBomb Members


TimeBomb Members

[image] [image]

SeriousBit Ellipter Documentaton
TimeBomb Members
TimeBomb Class Constructors Methods Properties See Also Send Feedback

The TimeBomb type exposes the following members.

Constructors

 | Name | Description
Public method | TimeBomb | Constructor

Methods

 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Reset | Removes all bomb records and resets State property to NonStarted.
Public method | Save | Saves bomb records
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Update | Reads, updates and saves bomb records

Properties

 | Name | Description
Public property | BackTimeTolerance | Sets and gets the maximum time interval (in seconds) that the bomb can tolerate when calculating IsHacked property. The default and recomended value is 3601 (1 hour + 1 second), to prevent IsHacked misfires when the time switches back from DST.
Public property | DaysLeft | Gets the number of days left until the bomb expires
Public property | EndDate | Gets the date of last trial day
Public property | IsExpired | Gets and sets a value indicating whether the trial is expired or not
Public property | IsHacked | Returns 'true' when users attempts to hack the bomb by reverting system time. If IsHacked is true then IsExpired is also true.
Public property | IsStarted | Gets a value indicating whether the bomb is started or not. The bomb starts after first Update() call and can become non-started after Reset() call
Public property | IsTrialActive | Returns true if the current date is within limits of trial.
Public property | LastRun | Returns the date of previous Update() call (usualy the same as last application run)
Public property | StartDate | Gets and sets first run date
Public property | State | Gets bomb's current state
Public property | TrialLength | Gets trial length in days

See Also

TimeBomb Class


TimeBomb Constructor

[image]

SeriousBit Ellipter Documentaton
TimeBomb Constructor
TimeBomb Class See Also Send Feedback
Constructor

Namespace: SeriousBit.Ellipter
Assembly: SeriousBit.Ellipter (in SeriousBit.Ellipter.dll) Version: 2.0.0.0

Syntax

C#
public TimeBomb(
    int trialLength,
    Guid productID
)
Visual Basic
Public Sub New ( _
    trialLength As Integer, _
    productID As Guid _
)
Visual C++
public:
TimeBomb(
    int trialLength,
    Guid productID
)

Parameters

trialLength
Type: System..::..Int32
The length, in days, of trial period
productID
Type: System..::..Guid
Used to store bomb records uniquely

See Also

TimeBomb Class


TimeBomb Methods

[image] [image]

SeriousBit Ellipter Documentaton
TimeBomb Methods
TimeBomb Class See Also Send Feedback

The TimeBomb type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Reset | Removes all bomb records and resets State property to NonStarted.
Public method | Save | Saves bomb records
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Update | Reads, updates and saves bomb records

See Also

TimeBomb Class


Dispose Method

[image]

SeriousBit Ellipter Documentaton
TimeBomb..::..Dispose Method
TimeBomb Class See Also Send Feedback
Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.

Namespace: SeriousBit.Ellipter
Assembly: SeriousBit.Ellipter (in SeriousBit.Ellipter.dll) Version: 2.0.0.0

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

TimeBomb Class


Reset Method

[image]

SeriousBit Ellipter Documentaton
TimeBomb..::..Reset Method
TimeBomb Class See Also Send Feedback
Removes all bomb records and resets State property to NonStarted.

Namespace: SeriousBit.Ellipter
Assembly: SeriousBit.Ellipter (in SeriousBit.Ellipter.dll) Version: 2.0.0.0

Syntax

C#
public void Reset()
Visual Basic
Public Sub Reset
Visual C++
public:
void Reset()

See Also

TimeBomb Class


Save Method

[image]

SeriousBit Ellipter Documentaton
TimeBomb..::..Save Method
TimeBomb Class See Also Send Feedback
Saves bomb records

Namespace: SeriousBit.Ellipter
Assembly: SeriousBit.Ellipter (in SeriousBit.Ellipter.dll) Version: 2.0.0.0

Syntax

C#
public void Save()
Visual Basic
Public Sub Save
Visual C++
public:
void Save()

See Also

TimeBomb Class


Update Method

[image]

SeriousBit Ellipter Documentaton
TimeBomb..::..Update Method
TimeBomb Class See Also Send Feedback
Reads, updates and saves bomb records

Namespace: SeriousBit.Ellipter
Assembly: SeriousBit.Ellipter (in SeriousBit.Ellipter.dll) Version: 2.0.0.0

Syntax

C#
public void Update()
Visual Basic
Public Sub Update
Visual C++
public:
void Update()

See Also

TimeBomb Class


TimeBomb Properties

[image] [image]

SeriousBit Ellipter Documentaton
TimeBomb Properties
TimeBomb Class See Also Send Feedback

The TimeBomb type exposes the following members.

Properties

 | Name | Description
Public property | BackTimeTolerance | Sets and gets the maximum time interval (in seconds) that the bomb can tolerate when calculating IsHacked property. The default and recomended value is 3601 (1 hour + 1 second), to prevent IsHacked misfires when the time switches back from DST.
Public property | DaysLeft | Gets the number of days left until the bomb expires
Public property | EndDate | Gets the date of last trial day
Public property | IsExpired | Gets and sets a value indicating whether the trial is expired or not
Public property | IsHacked | Returns 'true' when users attempts to hack the bomb by reverting system time. If IsHacked is true then IsExpired is also true.
Public property | IsStarted | Gets a value indicating whether the bomb is started or not. The bomb starts after first Update() call and can become non-started after Reset() call
Public property | IsTrialActive | Returns true if the current date is within limits of trial.
Public property | LastRun | Returns the date of previous Update() call (usualy the same as last application run)
Public property | StartDate | Gets and sets first run date
Public property | State | Gets bomb's current state
Public property | TrialLength | Gets trial length in days

See Also

TimeBomb Class


BackTimeTolerance Property

[image]

SeriousBit Ellipter Documentaton
TimeBomb..::..BackTimeTolerance Property
TimeBomb Class See Also Send Feedback
Sets and gets the maximum time interval (in seconds) that the bomb can tolerate when calculating IsHacked property. The default and recomended value is 3601 (1 hour + 1 second), to prevent IsHacked misfires when the time switches back from DST.

Namespace: SeriousBit.Ellipter
Assembly: SeriousBit.Ellipter (in SeriousBit.Ellipter.dll) Version: 2.0.0.0

Syntax

C#
public long BackTimeTolerance { get; set; }
Visual Basic
Public Property BackTimeTolerance As Long
    Get
    Set
Visual C++
public:
property long long BackTimeTolerance {
    long long get ();
    void set (long long value);
}

See Also

TimeBomb Class


DaysLeft Property

[image]

SeriousBit Ellipter Documentaton
TimeBomb..::..DaysLeft Property
TimeBomb Class See Also Send Feedback
Gets the number of days left until the bomb expires

Namespace: SeriousBit.Ellipter
Assembly: SeriousBit.Ellipter (in SeriousBit.Ellipter.dll) Version: 2.0.0.0

Syntax

C#
public int DaysLeft { get; }
Visual Basic
Public ReadOnly Property DaysLeft As Integer
    Get
Visual C++
public:
property int DaysLeft {
    int get ();
}

See Also

TimeBomb Class


EndDate Property

[image]

SeriousBit Ellipter Documentaton
TimeBomb..::..EndDate Property
TimeBomb Class See Also Send Feedback
Gets the date of last trial day

Namespace: SeriousBit.Ellipter
Assembly: SeriousBit.Ellipter (in SeriousBit.Ellipter.dll) Version: 2.0.0.0

Syntax

C#
public DateTime EndDate { get; }
Visual Basic
Public ReadOnly Property EndDate As DateTime
    Get
Visual C++
public:
property DateTime EndDate {
    DateTime get ();
}

See Also

TimeBomb Class


IsExpired Property

[image]

SeriousBit Ellipter Documentaton
TimeBomb..::..IsExpired Property
TimeBomb Class See Also Send Feedback
Gets and sets a value indicating whether the trial is expired or not

Namespace: SeriousBit.Ellipter
Assembly: SeriousBit.Ellipter (in SeriousBit.Ellipter.dll) Version: 2.0.0.0

Syntax

C#
public bool IsExpired { get; set; }
Visual Basic
Public Property IsExpired As Boolean
    Get
    Set
Visual C++
public:
property bool IsExpired {
    bool get ();
    void set (bool value);
}

See Also

TimeBomb Class


IsHacked Property

[image]

SeriousBit Ellipter Documentaton
TimeBomb..::..IsHacked Property
TimeBomb Class See Also Send Feedback
Returns 'true' when users attempts to hack the bomb by reverting system time. If IsHacked is true then IsExpired is also true.

Namespace: SeriousBit.Ellipter
Assembly: SeriousBit.Ellipter (in SeriousBit.Ellipter.dll) Version: 2.0.0.0

Syntax

C#
public bool IsHacked { get; }
Visual Basic
Public ReadOnly Property IsHacked As Boolean
    Get
Visual C++
public:
property bool IsHacked {
    bool get ();
}

See Also

TimeBomb Class


IsStarted Property

[image]

SeriousBit Ellipter Documentaton
TimeBomb..::..IsStarted Property
TimeBomb Class See Also Send Feedback
Gets a value indicating whether the bomb is started or not. The bomb starts after first Update() call and can become non-started after Reset() call

Namespace: SeriousBit.Ellipter
Assembly: SeriousBit.Ellipter (in SeriousBit.Ellipter.dll) Version: 2.0.0.0

Syntax

C#
public bool IsStarted { get; }
Visual Basic
Public ReadOnly Property IsStarted As Boolean
    Get
Visual C++
public:
property bool IsStarted {
    bool get ();
}

See Also

TimeBomb Class


IsTrialActive Property

[image]

SeriousBit Ellipter Documentaton
TimeBomb..::..IsTrialActive Property
TimeBomb Class See Also Send Feedback
Returns true if the current date is within limits of trial.

Namespace: SeriousBit.Ellipter
Assembly: SeriousBit.Ellipter (in SeriousBit.Ellipter.dll) Version: 2.0.0.0

Syntax

C#
public bool IsTrialActive { get; }
Visual Basic
Public ReadOnly Property IsTrialActive As Boolean
    Get
Visual C++
public:
property bool IsTrialActive {
    bool get ();
}

See Also

TimeBomb Class


LastRun Property

[image]

SeriousBit Ellipter Documentaton
TimeBomb..::..LastRun Property
TimeBomb Class See Also Send Feedback
Returns the date of previous Update() call (usualy the same as last application run)

Namespace: SeriousBit.Ellipter
Assembly: SeriousBit.Ellipter (in SeriousBit.Ellipter.dll) Version: 2.0.0.0

Syntax

C#
public DateTime LastRun { get; }
Visual Basic
Public ReadOnly Property LastRun As DateTime
    Get
Visual C++
public:
property DateTime LastRun {
    DateTime get ();
}

See Also

TimeBomb Class


StartDate Property

[image]

SeriousBit Ellipter Documentaton
TimeBomb..::..StartDate Property
TimeBomb Class See Also Send Feedback
Gets and sets first run date

Namespace: SeriousBit.Ellipter
Assembly: SeriousBit.Ellipter (in SeriousBit.Ellipter.dll) Version: 2.0.0.0

Syntax

C#
public DateTime StartDate { get; set; }
Visual Basic
Public Property StartDate As DateTime
    Get
    Set
Visual C++
public:
property DateTime StartDate {
    DateTime get ();
    void set (DateTime value);
}

See Also

TimeBomb Class


State Property

[image]

SeriousBit Ellipter Documentaton
TimeBomb..::..State Property
TimeBomb Class See Also Send Feedback
Gets bomb's current state

Namespace: SeriousBit.Ellipter
Assembly: SeriousBit.Ellipter (in SeriousBit.Ellipter.dll) Version: 2.0.0.0

Syntax

C#
public BombState State { get; }
Visual Basic
Public ReadOnly Property State As BombState
    Get
Visual C++
public:
property BombState State {
    BombState get ();
}

See Also

TimeBomb Class


TrialLength Property

[image]

SeriousBit Ellipter Documentaton
TimeBomb..::..TrialLength Property
TimeBomb Class See Also Send Feedback
Gets trial length in days

Namespace: SeriousBit.Ellipter
Assembly: SeriousBit.Ellipter (in SeriousBit.Ellipter.dll) Version: 2.0.0.0

Syntax

C#
public int TrialLength { get; }
Visual Basic
Public ReadOnly Property TrialLength As Integer
    Get
Visual C++
public:
property int TrialLength {
    int get ();
}

See Also

TimeBomb Class


UsageBomb Class

[image]

SeriousBit Ellipter Documentaton
UsageBomb Class
Members See Also Send Feedback
Provides functionality for uses count limited trial application

Namespace: SeriousBit.Ellipter
Assembly: SeriousBit.Ellipter (in SeriousBit.Ellipter.dll) Version: 2.0.0.0

Syntax

C#
public class UsageBomb : IDisposable
Visual Basic
Public Class UsageBomb _
    Implements IDisposable
Visual C++
public ref class UsageBomb : IDisposable

Inheritance Hierarchy

System..::..Object
SeriousBit.Ellipter..::..UsageBomb

See Also

UsageBomb Members


UsageBomb Members

[image] [image]

SeriousBit Ellipter Documentaton
UsageBomb Members
UsageBomb Class Constructors Methods Properties See Also Send Feedback

The UsageBomb type exposes the following members.

Constructors

 | Name | Description
Public method | UsageBomb | Constructor

Methods

 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Load | Reads and evaluates bomb's records, but doesn't save them
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Reset | Removes all bomb records and resets State property to NonStarted
Public method | Save | Saves bomb records
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Update | Reads, evaluates and saves bomb records

Properties

 | Name | Description
Public property | BackTimeTolerance | Sets and gets the maximum time interval (in seconds) that the bomb can tolerate when calculating IsHacked property. The default and recomended value is 3601 (1 hour + 1 second), to prevent IsHacked misfires when the time switches back from DST.
Public property | CountUsageOncePerDay | If true then usage will be counted only once per day
Public property | IsExpired | Gets and sets a value indicating whether the trial is expired or not
Public property | IsHacked | Returns 'true' when users attempts to hack the bomb by reverting system time and CountUsageOncePerDay is set to 'true' If IsHacked is true then IsExpired is also true.
Public property | IsStarted | Gets a value indicating whether the bomb is started or not. The bomb starts after first Update() call and can become non-started after Reset() call
Public property | IsTrialActive | Returns true if the current usage count is less than trial maximum.
Public property | LastRun | Returns the date of previous bomb run
Public property | MaxUsage | Gets maximum usage count
Public property | StartDate | Gets and sets first run date
Public property | State | Gets bomb's current state
Public property | UsageCount | Gets the count of bomb uses
Public property | UsageLeft | Gets the amount of uses left

See Also

UsageBomb Class


UsageBomb Constructor

[image]

SeriousBit Ellipter Documentaton
UsageBomb Constructor
UsageBomb Class See Also Send Feedback
Constructor

Namespace: SeriousBit.Ellipter
Assembly: SeriousBit.Ellipter (in SeriousBit.Ellipter.dll) Version: 2.0.0.0

Syntax

C#
public UsageBomb(
    int maxUsage,
    bool countUsageOncePerDay,
    Guid productID
)
Visual Basic
Public Sub New ( _
    maxUsage As Integer, _
    countUsageOncePerDay As Boolean, _
    productID As Guid _
)
Visual C++
public:
UsageBomb(
    int maxUsage,
    bool countUsageOncePerDay,
    Guid productID
)

Parameters

maxUsage
Type: System..::..Int32
Maximum usage count
countUsageOncePerDay
Type: System..::..Boolean
If true then usage will be counted only once per day
productID
Type: System..::..Guid
Used to store bomb records uniquely

See Also

UsageBomb Class


UsageBomb Methods

[image] [image]

SeriousBit Ellipter Documentaton
UsageBomb Methods
UsageBomb Class See Also Send Feedback

The UsageBomb type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Load | Reads and evaluates bomb's records, but doesn't save them
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Reset | Removes all bomb records and resets State property to NonStarted
Public method | Save | Saves bomb records
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Update | Reads, evaluates and saves bomb records

See Also

UsageBomb Class


Dispose Method

[image]

SeriousBit Ellipter Documentaton
UsageBomb..::..Dispose Method
UsageBomb Class See Also Send Feedback
Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.

Namespace: SeriousBit.Ellipter
Assembly: SeriousBit.Ellipter (in SeriousBit.Ellipter.dll) Version: 2.0.0.0

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

UsageBomb Class


Load Method

[image]

SeriousBit Ellipter Documentaton
UsageBomb..::..Load Method
UsageBomb Class See Also Send Feedback
Reads and evaluates bomb's records, but doesn't save them

Namespace: SeriousBit.Ellipter
Assembly: SeriousBit.Ellipter (in SeriousBit.Ellipter.dll) Version: 2.0.0.0

Syntax

C#
public void Load()
Visual Basic
Public Sub Load
Visual C++
public:
void Load()

See Also

UsageBomb Class


Reset Method

[image]

SeriousBit Ellipter Documentaton
UsageBomb..::..Reset Method
UsageBomb Class See Also Send Feedback
Removes all bomb records and resets State property to NonStarted

Namespace: SeriousBit.Ellipter
Assembly: SeriousBit.Ellipter (in SeriousBit.Ellipter.dll) Version: 2.0.0.0

Syntax

C#
public void Reset()
Visual Basic
Public Sub Reset
Visual C++
public:
void Reset()

See Also

UsageBomb Class


Save Method

[image]

SeriousBit Ellipter Documentaton
UsageBomb..::..Save Method
UsageBomb Class See Also Send Feedback
Saves bomb records

Namespace: SeriousBit.Ellipter
Assembly: SeriousBit.Ellipter (in SeriousBit.Ellipter.dll) Version: 2.0.0.0

Syntax

C#
public void Save()
Visual Basic
Public Sub Save
Visual C++
public:
void Save()

See Also

UsageBomb Class


Update Method

[image]

SeriousBit Ellipter Documentaton
UsageBomb..::..Update Method
UsageBomb Class See Also Send Feedback
Reads, evaluates and saves bomb records

Namespace: SeriousBit.Ellipter
Assembly: SeriousBit.Ellipter (in SeriousBit.Ellipter.dll) Version: 2.0.0.0

Syntax

C#
public void Update()
Visual Basic
Public Sub Update
Visual C++
public:
void Update()

See Also

UsageBomb Class


UsageBomb Properties

[image] [image]

SeriousBit Ellipter Documentaton
UsageBomb Properties
UsageBomb Class See Also Send Feedback

The UsageBomb type exposes the following members.

Properties

 | Name | Description
Public property | BackTimeTolerance | Sets and gets the maximum time interval (in seconds) that the bomb can tolerate when calculating IsHacked property. The default and recomended value is 3601 (1 hour + 1 second), to prevent IsHacked misfires when the time switches back from DST.
Public property | CountUsageOncePerDay | If true then usage will be counted only once per day
Public property | IsExpired | Gets and sets a value indicating whether the trial is expired or not
Public property | IsHacked | Returns 'true' when users attempts to hack the bomb by reverting system time and CountUsageOncePerDay is set to 'true' If IsHacked is true then IsExpired is also true.
Public property | IsStarted | Gets a value indicating whether the bomb is started or not. The bomb starts after first Update() call and can become non-started after Reset() call
Public property | IsTrialActive | Returns true if the current usage count is less than trial maximum.
Public property | LastRun | Returns the date of previous bomb run
Public property | MaxUsage | Gets maximum usage count
Public property | StartDate | Gets and sets first run date
Public property | State | Gets bomb's current state
Public property | UsageCount | Gets the count of bomb uses
Public property | UsageLeft | Gets the amount of uses left

See Also

UsageBomb Class


BackTimeTolerance Property

[image]

SeriousBit Ellipter Documentaton
UsageBomb..::..BackTimeTolerance Property
UsageBomb Class See Also Send Feedback
Sets and gets the maximum time interval (in seconds) that the bomb can tolerate when calculating IsHacked property. The default and recomended value is 3601 (1 hour + 1 second), to prevent IsHacked misfires when the time switches back from DST.

Namespace: SeriousBit.Ellipter
Assembly: SeriousBit.Ellipter (in SeriousBit.Ellipter.dll) Version: 2.0.0.0

Syntax

C#
public long BackTimeTolerance { get; set; }
Visual Basic
Public Property BackTimeTolerance As Long
    Get
    Set
Visual C++
public:
property long long BackTimeTolerance {
    long long get ();
    void set (long long value);
}

See Also

UsageBomb Class


CountUsageOncePerDay Property

[image]

SeriousBit Ellipter Documentaton
UsageBomb..::..CountUsageOncePerDay Property
UsageBomb Class See Also Send Feedback
If true then usage will be counted only once per day

Namespace: SeriousBit.Ellipter
Assembly: SeriousBit.Ellipter (in SeriousBit.Ellipter.dll) Version: 2.0.0.0

Syntax

C#
public bool CountUsageOncePerDay { get; set; }
Visual Basic
Public Property CountUsageOncePerDay As Boolean
    Get
    Set
Visual C++
public:
property bool CountUsageOncePerDay {
    bool get ();
    void set (bool value);
}

See Also

UsageBomb Class


IsExpired Property

[image]

SeriousBit Ellipter Documentaton
UsageBomb..::..IsExpired Property
UsageBomb Class See Also Send Feedback
Gets and sets a value indicating whether the trial is expired or not

Namespace: SeriousBit.Ellipter
Assembly: SeriousBit.Ellipter (in SeriousBit.Ellipter.dll) Version: 2.0.0.0

Syntax

C#
public bool IsExpired { get; set; }
Visual Basic
Public Property IsExpired As Boolean
    Get
    Set
Visual C++
public:
property bool IsExpired {
    bool get ();
    void set (bool value);
}

See Also

UsageBomb Class


IsHacked Property

[image]

SeriousBit Ellipter Documentaton
UsageBomb..::..IsHacked Property
UsageBomb Class See Also Send Feedback
Returns 'true' when users attempts to hack the bomb by reverting system time and CountUsageOncePerDay is set to 'true' If IsHacked is true then IsExpired is also true.

Namespace: SeriousBit.Ellipter
Assembly: SeriousBit.Ellipter (in SeriousBit.Ellipter.dll) Version: 2.0.0.0

Syntax

C#
public bool IsHacked { get; }
Visual Basic
Public ReadOnly Property IsHacked As Boolean
    Get
Visual C++
public:
property bool IsHacked {
    bool get ();
}

See Also

UsageBomb Class


IsStarted Property

[image]

SeriousBit Ellipter Documentaton
UsageBomb..::..IsStarted Property
UsageBomb Class See Also Send Feedback
Gets a value indicating whether the bomb is started or not. The bomb starts after first Update() call and can become non-started after Reset() call

Namespace: SeriousBit.Ellipter
Assembly: SeriousBit.Ellipter (in SeriousBit.Ellipter.dll) Version: 2.0.0.0

Syntax

C#
public bool IsStarted { get; }
Visual Basic
Public ReadOnly Property IsStarted As Boolean
    Get
Visual C++
public:
property bool IsStarted {
    bool get ();
}

See Also

UsageBomb Class


IsTrialActive Property

[image]

SeriousBit Ellipter Documentaton
UsageBomb..::..IsTrialActive Property
UsageBomb Class See Also Send Feedback
Returns true if the current usage count is less than trial maximum.

Namespace: SeriousBit.Ellipter
Assembly: SeriousBit.Ellipter (in SeriousBit.Ellipter.dll) Version: 2.0.0.0

Syntax

C#
public bool IsTrialActive { get; }
Visual Basic
Public ReadOnly Property IsTrialActive As Boolean
    Get
Visual C++
public:
property bool IsTrialActive {
    bool get ();
}

See Also

UsageBomb Class


LastRun Property

[image]

SeriousBit Ellipter Documentaton
UsageBomb..::..LastRun Property
UsageBomb Class See Also Send Feedback
Returns the date of previous bomb run

Namespace: SeriousBit.Ellipter
Assembly: SeriousBit.Ellipter (in SeriousBit.Ellipter.dll) Version: 2.0.0.0

Syntax

C#
public DateTime LastRun { get; }
Visual Basic
Public ReadOnly Property LastRun As DateTime
    Get
Visual C++
public:
property DateTime LastRun {
    DateTime get ();
}

See Also

UsageBomb Class


MaxUsage Property

[image]

SeriousBit Ellipter Documentaton
UsageBomb..::..MaxUsage Property
UsageBomb Class See Also Send Feedback
Gets maximum usage count

Namespace: SeriousBit.Ellipter
Assembly: SeriousBit.Ellipter (in SeriousBit.Ellipter.dll) Version: 2.0.0.0

Syntax

C#
public int MaxUsage { get; }
Visual Basic
Public ReadOnly Property MaxUsage As Integer
    Get
Visual C++
public:
property int MaxUsage {
    int get ();
}

See Also

UsageBomb Class


StartDate Property

[image]

SeriousBit Ellipter Documentaton
UsageBomb..::..StartDate Property
UsageBomb Class See Also Send Feedback
Gets and sets first run date

Namespace: SeriousBit.Ellipter
Assembly: SeriousBit.Ellipter (in SeriousBit.Ellipter.dll) Version: 2.0.0.0

Syntax

C#
public DateTime StartDate { get; set; }
Visual Basic
Public Property StartDate As DateTime
    Get
    Set
Visual C++
public:
property DateTime StartDate {
    DateTime get ();
    void set (DateTime value);
}

See Also

UsageBomb Class


State Property

[image]

SeriousBit Ellipter Documentaton
UsageBomb..::..State Property
UsageBomb Class See Also Send Feedback
Gets bomb's current state

Namespace: SeriousBit.Ellipter
Assembly: SeriousBit.Ellipter (in SeriousBit.Ellipter.dll) Version: 2.0.0.0

Syntax

C#
public BombState State { get; }
Visual Basic
Public ReadOnly Property State As BombState
    Get
Visual C++
public:
property BombState State {
    BombState get ();
}

See Also

UsageBomb Class


UsageCount Property

[image]

SeriousBit Ellipter Documentaton
UsageBomb..::..UsageCount Property
UsageBomb Class See Also Send Feedback
Gets the count of bomb uses

Namespace: SeriousBit.Ellipter
Assembly: SeriousBit.Ellipter (in SeriousBit.Ellipter.dll) Version: 2.0.0.0

Syntax

C#
public int UsageCount { get; }
Visual Basic
Public ReadOnly Property UsageCount As Integer
    Get
Visual C++
public:
property int UsageCount {
    int get ();
}

See Also

UsageBomb Class


UsageLeft Property

[image]

SeriousBit Ellipter Documentaton
UsageBomb..::..UsageLeft Property
UsageBomb Class See Also Send Feedback
Gets the amount of uses left

Namespace: SeriousBit.Ellipter
Assembly: SeriousBit.Ellipter (in SeriousBit.Ellipter.dll) Version: 2.0.0.0

Syntax

C#
public int UsageLeft { get; }
Visual Basic
Public ReadOnly Property UsageLeft As Integer
    Get
Visual C++
public:
property int UsageLeft {
    int get ();
}

See Also

UsageBomb Class